I have an application that uses php's snmp support to gather some 
information.   I run several servers that are using this application and 
all of the servers are running redhat-7.2.   In redhat 7.2 the OS 
initially ships with ucd-snmp-4.2.1-7.i386.rpm.   This works fine with 
my applications.   I make every effort to keep these servers patched and 
up to date, and unfortunately redhat has released some ucd-snmp patches 
that bring the version up to ucd-snmp-4.2.5-7.72.0.i386.rpm.   When I 
try to install that version of snmp, the snmp support breaks in php. 
The output is completely whacked, and I wish I could explain more, but 
generally output that used to poll correctly now shows 0 and certain 
items show the OID<space>value instead of just the value.   So I'll have 
a column in the app that has
(ucd-snmp 4.2.1 output)
valuea                  25
(ucd-snmp 4.2.5 output)
valuea                  transmission.1.3.5.blah 2

The output is all over the place.   One thing that I do know has changed 
with this release of ucd-snmp is that it now comes with libwrap support. 
    Any way that could affect it.   I've tried recompiling php with the 
new includes.

Of course there are some patches that are dependent upon this working, 
so if anyone has any insight on how to proceed I would appreciate it. 
Any suggestions on how to get the most up to date ucd-snmp patches.   At 
this time my option is not to upgrade and it doesn't appear that there 
is a bug fix or anything else that is required in that newest release, 
however, the new redhat-7.3 boxes that I need to deploy in place of the 
redhat-7.2 boxes are going to probably have the same problem.


Brian Seppanen

PHP General Mailing List (http://www.php.net/)
To unsubscribe, visit: http://www.php.net/unsub.php

Reply via email to