Found another workaround to the libmcrypt problem.  What I did is to get
into the source directory that hold all of hte untarred source code.  I then
use the command, 'cp -r libmcrypt-2.5.3 /usr/local/lib' then I edit the
php.ini as shown ....

mcrypt.algorithms_dir =  /usr/local/lib/libmcrypt-2.5.3/modules/algorithms
mcrypt.modes_dir =  /usr/local/lib/libmcrypt-2.5.3/modules/modes

It work like a charm!!!!!!

"Scott Fletcher" <[EMAIL PROTECTED]> wrote in message
> Found the problem with libmcrypt-2.5.3.  When I configured PHP using
> the --with-mcrypt option and the PHP configuration found libmcrypt without
> problem.  After compiling and installing it.
> Once I fired up Apache.  I checked the PHP Info using phpinfo() function.
> The mcrypt showed up but there is no support ciphers (algorithms & modes).
> So, I had to use the php.ini as the PHP Manual stated on
> ''.  So, I added the two lines as shown in the
> where libmcrypt was installed in.
> --clip--
> mcrypt.algorithms_dir = /usr/local/lib/libmcrypt
> mcrypt.modes_dir = /usr/local/lib/libmcrypt
> --clip--
> That is when PHP Info showed the 'mcrypt.algorithms_dir' and
> 'mcrypt.modes_dir' with data in it.  But the problem is I still get the
> error message when I tried any mcrypt function, the error message range
> being unable to initalize the module to whatever the other error messages
> are.  I assumed there's a bug and filed a bug report to PHP but was
> because I was told that I had the php.ini incorrect.  That doesn't make
> sense.  It took me a long time to find some clues to the problem.  What I
> found is that with any files in the "/usr/local/lib/libmcrypt" that end
> *.a and *.la, they don't work.  There is no *.c and *.h files in that
> directory.
> I discovered that when I set the php.ini to point to the untarred
> directory where *.c and *.h are found in both
> '/usr/local/src4/libmcrypt-2.5.3/modules/algorithms' and
> '/usr/local/src4/libmcrypt-2.5.3/modules/modes'.  That's when the mcrypt
> function start working without a problem.  The problem is PHP doesn't work
> with the *.la and *.a files.  Again, I saw the OpenSSL directory where *.c
> and *.h files are found in both the algorithms and modes directory of the
> '/usr/local/ssl/include/openssl/' directory, it work just fine too.
> This had lead me to question of whether is there a bug in libmcrypt or
> You be the judge of it.  It would be so nice if this problem can be
> resolved.  I'm not sure if I'm allowed to use the open source code instead
> of the compiled codes.

PHP General Mailing List (
To unsubscribe, visit:

Reply via email to