Encountered the following problem with the Microsoft SQL Server interface.
I am not sure where the problem exists, but I am looking for a workaround.

I inserted a row into a table that contained a text column, and inserted
over 5kb string into the text field.  On retrieving the row the server
returned the column values truncated to 4096 bytes exactly.  Tried to code
SET TEXTSIZE nnn into my query string, the query refused to return anything
at all.  Then I tried coding SET TEXTSIZE as a separate query on the same
connection, just prior to my data query, both appeared to be successful, but
still only got 4096 bytes of data.

select DATALENGTH(availabilitySample) from mftsmainframeavailability where
availabilityID = 1

using the MSSQL 7 Query analyzer returns;

(1 row(s) affected)

This shows that my text was stored, I just can't seem to get the server (or
the interface) to give me back more than 4096 bytes.

any clues would be greatly appreciated.
thanks in advance,

Warren Vail
Tools, Metrics & Quality Processes

PHP General Mailing List (http://www.php.net/)
To unsubscribe, visit: http://www.php.net/unsub.php

Reply via email to