Thanks Brad! Dead on! 

Unfortunately, after the upgrade, the old php.ini was not saved, so I 
couldn't compare what the former employee changed in there. I turned that 
option on, restarted apache, and it worked. 


> This should be a FAQ!
> I would say it would point to register globals being turned off in php.ini for
> the newer versions of php. 
> check this pages for more information:
> -Brad 
> abw wrote: 
>> This week we upgraded our solaris 8 server using apache 1.3.27 from php
>> 4.1.2 to 4.2.3, and it seemed to install fine. The strange thing is that
>> most all php web pages appear, but the code does not work. For example, our
>> support section heavily uses php, and nothing at all was changed on it, yet
>> clicking any link takes you right back to the main page instead of the
>> appropriate support page.
>> Also, a customer that has a php page calling a mysql database suddently quit
>> working. These all worked fine before the upgrade, and like I say, none of
>> the web pages have been changed at all. 
>> I didn't find anything in the archives. 
>> Has anybody else experienced this? I assumed 4.1.2 to 4.2.3 should be a
>> seamless upgrade for all web pages, but apparently not. 
>> I can't find anything helpful in the log files either. 
>> Suggestions? 
>> Aaron 
>> --
>> PHP General Mailing List (
>> To unsubscribe, visit:

PHP General Mailing List (
To unsubscribe, visit:

Reply via email to