On Sat, 23 Nov 2002 10:58:02 -0500, you wrote: >> I am trying to generate arrays to hold inputs to columns. Column >> titles are input to a table as needed. They are read by the program >> and placed across the page. Then an array goes under each column name >> to collect the inputs to the various rows. Everything works except to >> dynamically change the name of the array. >> >> >> while($foo=mysql_fetch_array($mysql_result)){ >> print "<INPUT TYPE=text NAME=correspondingfoo[]>";} > >Do you want this?? > >print "<INPUT TYPE=text NAME=" . $foo['something'] . "[]>"; > >---John Holmes...
No John. I'm ok with simply inputting a value and otherwise using arrays that are hard coded and previously named but my problem is in creating different arrays on the fly to represent each column that there is a name for. I want to end up with something like $meat[] and $potatoes[] and whatever else is needed from a list... The list of meat, potatoes, etc determines how many arrays and their names. I'm not to swift when it comes to arrays and think I'm probably stuck on some simple misconception. I'm trying to convert $meat to $meat[], on the fly, to have something to input to... I read today maybe I don't need the brackets? Floyd -- -- PHP General Mailing List (http://www.php.net/) To unsubscribe, visit: http://www.php.net/unsub.php