So there is :-) .  Strange this it's just the order in which the
xsi:type and xmlns:tns are written out.  Given that, I would say it's
good to go, but we need to get to the bottom of why the order is
different between Windows and Linux to avoid this in future releases.

Agree? Disagree?

Graham.

On 22 Jun, 09:42, [EMAIL PROTECTED] wrote:
> On 22 Jun, 09:14, Graham Charters <[EMAIL PROTECTED]> wrote:
>
>
>
> > Hi Simon, can you post what you're seeing for one of the failing unit
> > test for comparison?
>
> > Graham.
>
> > On 22 Jun, 09:08, [EMAIL PROTECTED] wrote:
>
> > > On 22 Jun, 08:39, [EMAIL PROTECTED] wrote:
>
> > > > On 21 Jun, 22:40, Graham Charters <[EMAIL PROTECTED]> wrote:
>
> > > > > Hi Matthew,
>
> > > > > Thanks for fixing the wsdl schema fetching problem and spinning RC2.
> > > > > It all looks good to me on Windows.  Unit tests all pass (phpt and
> > > > > phpunit).  Service generation for wsdl, xmlrpc and jsonrpc all work.
> > > > > Json-rpc mail example runs.  Ebay soap example runs and caching works.
>
> > > > > Regards,
>
> > > > > Graham.
>
> > > > > On 21 Jun, 16:24, "Simon Laws" <[EMAIL PROTECTED]> wrote:
>
> > > > > > On 6/21/07, Matthew Peters <[EMAIL PROTECTED]> wrote:
>
> > > > > > > I just uploaded a new release candidate for DUNLIN (1.2.2) into 
> > > > > > > the
> > > > > > > files section of this google group. I deleted the previous one, 
> > > > > > > so the
> > > > > > > one that is there, and says it was uploaded at 8:10, is the one to
> > > > > > > try.
>
> > > > > > > wrt to the "going out on the web for no schemalocation" problem, I
> > > > > > > went for the following compromise:
>
> > > > > > > if (strstr(file_name,"2003-02-11.xsd")) {
> > > > > > >         xmldas->xsdHelperPtr->defineFile(file_name, false);
> > > > > > > } else {
> > > > > > >         xmldas->xsdHelperPtr->defineFile(file_name, true);
> > > > > > > }
>
> > > > > > > i.e., for our soap and wsdl xsds, don't go out, for others, do.
>
> > > > > > > Ok, Matthew, pragmatic as ever. It looks like the real fix is 
> > > > > > > going to
>
> > > > > > take a little time. Thanks for respinning the RC.
>
> > > > > > Simon
>
> > > > On FC6 I see 5 unit test failures and 1 phpt failure. They seem to be
> > > > to do with modification of the order of namespace definitions on
> > > > generated XML, for example,
>
> > > >  5) testGETForm(SCA_RestRpcTest)
> > > > Failed asserting that <text> is equal to <text>.
> > > > --- Expected
> > > > +++ Actual
> > > > @@ -1,2 +1,2 @@
> > > >  <?xml version="1.0" encoding="UTF-8"?>
> > > > -<HelloType xsi:type="HelloType" xmlns:tns="http://www.example.org/
> > > > Hello" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance";
> > > > xmlns="http://www.example.org/Hello";><name>name</name><greeting>Hello
> > > > Fred</greeting><reversed>derF olleH</reversed></HelloType>
> > > > +<HelloType xmlns="http://www.example.org/Hello"; xsi:type="HelloType"
> > > > xmlns:tns="http://www.example.org/Hello"; xmlns:xsi="http://www.w3.org/
> > > > 2001/XMLSchema-instance"><name>name</name><greeting>Hello Fred</
> > > > greeting><reversed>derF olleH</reversed></HelloType>
>
> > > > /usr/local/lib/php/test/SCA_SDO/tests/SCA/phpunit/RestRpc/
> > > > RestRpcTest.php:95
> > > > /usr/local/lib/php/test/SCA_SDO/tests/TestSuite.php:41
> > > > /usr/local/lib/php/test/SCA_SDO/tests/TestSuite.php:58
> > > > /usr/local/lib/php/test/SCA_SDO/tests/AllTests.php:28
>
> > > > I'm assuming this is to do with the WSDL validation changes but I
> > > > thought the test expect results had caught up with this. They don't
> > > > stop the samples running though.
>
> > > > I also have a problem running one of the JSONRPC samples which I think
> > > > is a configuration problem. Give me a little time to investigate this.
>
> > > > Simon
>
> > > So I have all the examples running ok now (was a curl config issue) so
> > > there can't be much wrong with it. Unit tests still fail. I can't just
> > > go fix the expected output for the tests though if you are not seeing
> > > these failures so I would like to know why our platforms are producing
> > > different output. Here's what I'm running.
>
> > > Fedora Core 6
> > > PHP 5.2.0
> > > libxml 2.6.29
>
> > > Simon
>
> > > Simon
>
> There is one in my original post


--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups 
"phpsoa" group.
To post to this group, send email to phpsoa@googlegroups.com
To unsubscribe from this group, send email to [EMAIL PROTECTED]
For more options, visit this group at 
http://groups.google.co.uk/group/phpsoa?hl=en
-~----------~----~----~----~------~----~------~--~---

Reply via email to