Status: New
Owner: ----

New issue 166 by Refactor PNode.moveToBack() and related

I would like to rename & refactor the Z-order methods in PNode to the following

Methods that change the Z-order of this

void raise();
void lower();
void raiseToTop();
void lowerToBottom();

Methods that change the Z-order of a child node

void raise(PNode child)
void lower(PNode child)
void raiseToTop(PNode child)
void lowerToBottom(PNode child)

I find the current methods, as defined in terms of their parent, rather
awkwardly defined as evidenced by Issue 165.

These new method names are the action names used in Inkscape.

You received this message because you are listed in the owner
or CC fields of this issue, or because you starred this issue.
You may adjust your issue notification preferences at:

Piccolo2D Developers Group:

Reply via email to