Rowan Thorpe <> writes:

>> On Wed, 17 Jul 2013 09:22:14 +0200
>> Thorsten Jolitz <> wrote:
>> ..[snip]..
>> I ran into this problem when experimenting with the
>> web-framework and my app got into a bad state. When restarting then,
>> PicoLisp tells me something like 'Port is already used', so I tried
>> to kill the still running (*) PicoLisp processes with a simple 'kill
>> PID', but to no avail.
>> [* are they still running? 'ps' shows them with a '?', and I
>> shutted them down on the command-line, so they shouldn't. But somehow
>> they still block the port, and the more I shut down, the more are
>> shown by 'ps']
>> ..[snip]..
> Sorry for asking the obvious question, but have you waited the couple of
> minutes needed for the kernel (depending on which kernel) to eventually
> clean orphaned ports itself? It *may* actually just be the port
> remaining open because the owning process didn't cleanly shut it?: as
> mentioned here

Not obvious for me, obviously, but definitely the right question - no I
did not wait, and I did not know I have to wait a couple of minutes. 

So thats probably the root of the problem, unrelated to PicoLisp. Though
a bit of a hassle, since it takes away the huge advantage of PicoLisp's
millisecond start-up time somehow, and shutting down a PicoLisp process
and restart is not a prime option anymore if a couple of minutes waiting
are involved. 

Thanks for the interesting link!



Reply via email to