On Sun, May 29, 2016 at 1:52 PM, David Bloom <ipro...@gmail.com> wrote:
> Hello List,

Hello David!

> I'm trying to make a PicoLisp container for development and scaling of
> PicoLisp applications.  At first I tried compiling within an Alpine Linux
> container and got musl errors, then tried in a 64-bit Tinycore linux
> container.
> Using latest source 16.2 I get the error below, any thoughts?  I'm not a C
> guy so this doesn't make much sense to me even when I look at the source
> code.  Thank you in advance for any suggestions, for the amazing language,
> and a very supportive community.
> ~/picoLisp/src $ gcc --version
> gcc (GCC) 5.2.0
> Copyright (C) 2015 Free Software Foundation, Inc.
> This is free software; see the source for copying conditions.  There is NO
> ~/picoLisp/src $ make --version
> GNU Make 4.1
> Built for x86_64-unknown-linux-gnu
> Copyright (C) 1988-2014 Free Software Foundation, Inc.
> License GPLv3+: GNU GPL version 3 or later
> <http://gnu.org/licenses/gpl.html>
> This is free software: you are free to change and redistribute it.
> There is NO WARRANTY, to the extent permitted by law.
> -------------------------------------------
> ~/picoLisp/src $ make
> gcc -c -O2 -pipe -falign-functions=32 -fomit-frame-pointer
> -fno-strict-aliasing -W -Wimplicit -Wreturn-type -Wunused -Wformat
> -Wuninitialized -Wstrict-prototypes -D_GNU_SOURCE  -D_FILE_OFFS
> ET_BITS=64 -m32 -D_OS='"Linux"' main.c
> In file included from /usr/include/features.h:389:0,
>                 from /usr/include/stdio.h:27,
>                 from pico.h:5,
>                 from main.c:5:
> /usr/include/gnu/stubs.h:7:27: fatal error: gnu/stubs-32.h: No such file or
> directory
> compilation terminated.
> Makefile:129: recipe for target 'main.o' failed
> make: *** [main.o] Error 1

I'm not a linux dood, but according to
"you're missing the 32 bit libc dev package."  (That would makes
sense, because at this point you are trying to build 32-bit picolisp.)

BTW, different linux distros call these packages with different names
(as indicated by the top answer at that URL), but also that the same
libs on different linux distros get installed to different locations.
Welcome to the circus that is development/building on linux. :)

> -------------------------------------------
> ~ $ cd picoLisp/src64/
> ~/picoLisp/src64 $ make
> ./mkAsm x86-64 ".linux" .s Linux base "" ../lib/map  version.l glob.l main.l
> gc.l apply.l flow.l sym.l subr.l big.l io.l db.l net.l err.l
> sys/x86-64.linux.code.l
> ../ersatz/pil: exec: line 5: java: not found
> Makefile:142: recipe for target 'x86-64.linux.base.s' failed
> make: *** [x86-64.linux.base.s] Error 2

This just means that the build process can't find java.  The `java`
executable has to be installed and on your PATH.

Good luck!

UNSUBSCRIBE: mailto:picolisp@software-lab.de?subject=Unsubscribe

Reply via email to