My experience with LXC is that they work just like a typical VM but
being a container they're faster and easier to handle. We've split up
our database over 10 LXC containers running MySQL, works great.

Caveat, we're using Ubuntu, I've gotten the impression that LXC is a
bit harder to setup in other distros.

My impression of Docker is that they've somehow reduced the
capabilities so that a docker container is not the equivalent of a
complete VM?

It's mostly because of this post:
https://www.flockport.com/lxc-vs-docker/ which is two years old soon
so things could've changed.



On Sat, Jun 4, 2016 at 5:43 AM, David Bloom <ipro...@gmail.com> wrote:
> I've got Triton elastic container infrastructure in mind in particular.  All
> of the security of Solaris zones plus tiny PicoLisp containers distributed
> over multiple servers with distributed storage = a very intriguing platform.
>
> I'm curious to hear about your experiences with LXC Henrik and thank you for
> the amazing tutorials by the way.  I've learned a great deal of PicoLisp
> from you, Alex, and the other contributors as well.
>
> Mike, I'll work on adding it to the glot list as well.
>
> Please note that now the image is available at:
> https://hub.docker.com/r/progit/docker-tinycore-picolisp/
>
> The name changed due to the way automated builds work with Docker Hub linked
> to a Github account.  Trimmed from 170MB down to 14MB!!!  This was done by
> copying a pre-compiled ./picoLisp/ into the image.  That should help with
> scaling.  Enjoy.
>
> On Tue, May 31, 2016 at 7:09 AM, Henrik Sarvell <hsarv...@gmail.com> wrote:
>>
>> I've got quite a lot of experience with LXC, can recommend highly if
>> Docker doesn't cut it.
>>
>>
>>
>> On Sun, May 29, 2016 at 7:52 PM, David Bloom <ipro...@gmail.com> wrote:
>>>
>>> Hello List,
>>>
>>> I'm trying to make a PicoLisp container for development and scaling of
>>> PicoLisp applications.  At first I tried compiling within an Alpine Linux
>>> container and got musl errors, then tried in a 64-bit Tinycore linux
>>> container.
>>>
>>> Using latest source 16.2 I get the error below, any thoughts?  I'm not a
>>> C guy so this doesn't make much sense to me even when I look at the source
>>> code.  Thank you in advance for any suggestions, for the amazing language,
>>> and a very supportive community.
>>>
>>> ~/picoLisp/src $ gcc --version
>>> gcc (GCC) 5.2.0
>>> Copyright (C) 2015 Free Software Foundation, Inc.
>>> This is free software; see the source for copying conditions.  There is
>>> NO
>>> warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR
>>> PURPOSE.
>>>
>>> ~/picoLisp/src $ make --version
>>> GNU Make 4.1
>>> Built for x86_64-unknown-linux-gnu
>>> Copyright (C) 1988-2014 Free Software Foundation, Inc.
>>> License GPLv3+: GNU GPL version 3 or later
>>> <http://gnu.org/licenses/gpl.html>
>>> This is free software: you are free to change and redistribute it.
>>> There is NO WARRANTY, to the extent permitted by law.
>>>
>>> -------------------------------------------
>>> ~/picoLisp/src $ make
>>> gcc -c -O2 -pipe -falign-functions=32 -fomit-frame-pointer
>>> -fno-strict-aliasing -W -Wimplicit -Wreturn-type -Wunused -Wformat
>>> -Wuninitialized -Wstrict-prototypes -D_GNU_SOURCE  -D_FILE_OFFS
>>> ET_BITS=64 -m32 -D_OS='"Linux"' main.c
>>> In file included from /usr/include/features.h:389:0,
>>>                 from /usr/include/stdio.h:27,
>>>                 from pico.h:5,
>>>                 from main.c:5:
>>> /usr/include/gnu/stubs.h:7:27: fatal error: gnu/stubs-32.h: No such file
>>> or directory
>>> compilation terminated.
>>> Makefile:129: recipe for target 'main.o' failed
>>> make: *** [main.o] Error 1
>>>
>>> -------------------------------------------
>>> ~ $ cd picoLisp/src64/
>>> ~/picoLisp/src64 $ make
>>> ./mkAsm x86-64 ".linux" .s Linux base "" ../lib/map  version.l glob.l
>>> main.l gc.l apply.l flow.l sym.l subr.l big.l io.l db.l net.l err.l
>>> sys/x86-64.linux.code.l
>>> ../ersatz/pil: exec: line 5: java: not found
>>> Makefile:142: recipe for target 'x86-64.linux.base.s' failed
>>> make: *** [x86-64.linux.base.s] Error 2
>>>
>>
>
-- 
UNSUBSCRIBE: mailto:picolisp@software-lab.de?subject=Unsubscribe

Reply via email to