How are you getting the Android Studio SDK (referred to as '../Sdk/' in the
README)? I tried getting it from

but it did not have the expected directory structure and I could not find
''. I also tried using the Android Studio IDE
and various arch linux packages, but none seemed to produce the expected
directory structure.

Instead I grabbed the Android NDK from

which includes 'build/tools/'.

Using that to build the toolchain into 'PilBox/' seems to work fine, as all
the files needed for 'mk.arm64.linux' are in the right places. Then, at
some point during the build ('./mk.arm64.linux') process,
'toolchain/bin/clang38' is executed (presumably from
'toolchain/bin/aarch64-linux-android-clang'?). And 'clang38' expects
ncurses? I'm just as confused as you here.

I'm guessing the problem is that I'm using the NDK instead? Probably should
have mentioned that in my first mail...


On Apr 2, 2017 8:10 AM, "Alexander Burger" <> wrote:

He Erik,

> preparing the toolchain, but './mk.arm64.linux' fails with the following
> (abridged) error messages:
>    ../../toolchain/bin/clang38: error while loading shared libraries:
> no such file

This makes absolutely no sense to me. Ncurses should not be needed anywhere
build the binary.

Can you find out more about the context?

♪♫ Alex

Reply via email to