Hello Patrick,

it's indeed an odd issue. Check the following:

- you can connect to the mysql piler database, can see and read from the tables
- /var/piler/{store,tmp} dirs and contents are owned by piler
- copy an eml file to the new host, and verify that pilertest can process it fine


On 2023-05-31 08:39, patrick.we...@rgi.net wrote:

I was trying to migrate my old piler 1.2.0 to a new host with piler

1. Specs of the old host:
    - Piler Version 1.2 build 952
    -  Debian 9

2. Specs of the new host:
    - Piler Version 1.4.2 build 1001
    - Ubuntu 22.04

3. Installed Piler 1.4.2 on new host
4. Disabled all Cronjobs on new
5. Stopped Piler Service on old: systemctl stop rc.piler.service
6. Stopped Searchd on old: systemctl stop rc.searchd.service
7. Stopped mysql on old
8. Copied the piler.key, the old host does not have an iv configured
8. Copied the mysql data from /var/lib/mysql/*
9. Created a tar archive of the sphinx files at /var/piler/sphinx: tar
-czvf sphinx.tar.gz ./
10. Uploaded the MySQL-files and sphinx files to the new hosts
11. Started piler, searchd and mysql on new
12. Uploaded /var/piler/store/* to the new host
13. Enabled the cronjobs on new
14. Started a reindex (reindex -a) -> Segmentation fault
15. Tried to read a mail with pilerget -> Segmentation fault

I also have tried many more solutions in the past.
The first solutions was to upgrade the piler version of the old piler
to 1.4.2 and then copy the files in /var/piler/sphinx/*,
/var/piler/store/* and /var/lib/mysql/*
to the new piler. I used the migration documentation on
https://www.mailpiler.org/wiki/current:migration-to-new-host [1].
After i have imported all files i tried to run a reindex. The result
was a segmentation fault error.
The second solution was similar to the first. The only difference is
that i made a dump of the sql-database and read it into the piler
database. But the result was the same (segmentation fault).

Another thing i have realized while upgrading the piler is, that the
documentation on the schema update for the mysql database on the
website (https://www.mailpiler.org/wiki/current:upgrade) differs from
upgrades in the installation files.


Reply via email to