Source: toxiproxy
Version: 2.0.0+dfsg1-1
Severity: serious
Justification: fails to build from source (but built successfully in the past)

Automated builds of toxiproxy have been failing to start because its
build dependencies include

    golang-mux-dev | golang-github-gorilla-mux-dev

golang-github-gorilla-mux-dev has replaced golang-mux-dev in the
archive, but the autobuilders don't care because they ignore
alternative dependencies for the sake of determinism (unless
architecture qualifiers explicitly eliminate earlier options).
Please either flip this dependency or specify just
golang-github-gorilla-mux-dev.

Likewise for golang-logrus-dev | golang-github-sirupsen-logrus-dev;
although there's still a transitional golang-logrus-dev package in the
archive, you shouldn't count on its long-term availability.

Thanks!

-- System Information:
Debian Release: stretch/sid
  APT prefers testing
  APT policy: (500, 'testing'), (500, 'stable'), (300, 'unstable')
Architecture: amd64 (x86_64)
Foreign Architectures: i386

Kernel: Linux 4.5.0-2-amd64 (SMP w/4 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)

-- no debconf information

_______________________________________________
Pkg-go-maintainers mailing list
Pkg-go-maintainers@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-go-maintainers

Reply via email to