Your message dated Sun, 16 Oct 2016 13:24:43 +0100
with message-id <>
and subject line Re: Multi-line ARGS assignment in 
/etc/default/prometheus-node-exporter not suppored by systemd
has caused the Debian Bug report #840947,
regarding Multi-line ARGS assignment in /etc/default/prometheus-node-exporter 
not suppored by systemd
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact

Debian Bug Tracking System
Contact with problems
--- Begin Message ---
Package: prometheus-node-exporter
Version: 0.12.0+ds+really0.12.0-2
Severity: minor

When prometheus-node-exporter starts, the following message is logged:

systemd[1]: prometheus-node-exporter.service: Ignoring invalid environment 
assignment 'ARGS=-collector.diskstats.ignored-devices=^(ram|loop|fd)d+$
systemd[1]: Started Prometheus exporter for machine metrics.

The arguments set in that file are therefore not actaully passed to the

-- System Information:
Debian Release: 8.6
  APT prefers stable-updates
  APT policy: (550, 'stable-updates'), (550, 'stable'), (530, 'testing'), (520, 
'unstable'), (500, 'testing-updates'), (1, 'experimental')
Architecture: i386 (i686)

Kernel: Linux 4.7.0-0.bpo.1-686-pae (SMP w/1 CPU core)
Locale: LANG=en_GB.UTF-8, LC_CTYPE=en_GB.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)

Versions of packages prometheus-node-exporter depends on:
ii  daemon  0.6.4-1
ii  libc6   2.19-18+deb8u6

prometheus-node-exporter recommends no packages.

prometheus-node-exporter suggests no packages.

-- Configuration Files:
/etc/default/prometheus-node-exporter changed [not included]

-- no debconf information

--- End Message ---
--- Begin Message ---
Ugh, I just realised that this was my error, not an error in
/etc/default/prometheus-node-exporter as shipped by the package. Sorry
for the noise!

Sam Morris <>

--- End Message ---
Pkg-go-maintainers mailing list

Reply via email to