Package: gitlab-ci-multi-runner
Version: 1.7.1+dfsg-1
Severity: important


  During the installation of the Debian package,
There is two problems:
1) the cdebootstrap command is failing. I do not know why
  but the current result (can be easily reproduced) is :
  # cdebootstrap     --flavour=minimal     
--include="bash,ca-certificates,git,netcat-traditional"     stable 
  P: Configuring package apt
  P: Configuring helper cdebootstrap-helper-apt
  E: Internal error: install

  The script continues but produce a image that does not
  have the required tools (git in particular)

  => docker is unusable.

2) does not report this problem and the postinst
  does not fail (hence the 'important' severity)
  It tooks me lot of time to discover that
  1) a special docker image is used to clone the repo
  2) this special image is corrupted (the 'E: Internal error: install' can
    be seen in the log file whose name is displayed during the package
    configuration). But, as the package installs fine, I do not suspect
    a problem here until I really llok in depth.

Note that this is a Debian specific bug, as I eventually found:

  Perhaps, this bug can be duplicated and the first part reassigned
to cdeboostrap (the second part is really about this package)
if the cdeboostrap invocation is correct (I do not know cdeboostrap).


-- System Information:
Debian Release: stretch/sid
  APT prefers stable-updates
  APT policy: (500, 'stable-updates'), (500, 'unstable'), (500, 'testing'), 
(200, 'stable'), (1, 'experimental')
Architecture: amd64 (x86_64)
Foreign Architectures: i386, armel, mipsel

Kernel: Linux 4.7.0-1-amd64 (SMP w/8 CPU cores)
Locale: LANG=fr_FR.utf8, LC_CTYPE=fr_FR.utf8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)

Versions of packages gitlab-ci-multi-runner depends on:
ii  adduser              3.115
ii  ca-certificates      20160104
ii  git                  1:2.10.1-1
ii  init-system-helpers  1.45
ii  libc6                2.24-5
ii  lsb-base             9.20161016

Versions of packages gitlab-ci-multi-runner recommends:
ii  cdebootstrap  0.7.5

Versions of packages gitlab-ci-multi-runner suggests:
ii  1.11.2~ds1-6

-- Configuration Files:
/etc/gitlab-runner/config.toml [Errno 13] Permission non accordée: 

-- no debconf information

Pkg-go-maintainers mailing list

Reply via email to