Your message dated Wed, 25 Jun 2008 12:02:11 +0000
with message-id <[EMAIL PROTECTED]>
and subject line Bug#441797: fixed in postgis 1.3.3-3
has caused the Debian Bug report #441797,
regarding postgresql-8.2-postgis: upgrade to 1.3.1 make old databases unusable
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact [EMAIL PROTECTED]
immediately.)


-- 
441797: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=441797
Debian Bug Tracking System
Contact [EMAIL PROTECTED] with problems
--- Begin Message ---
Package: postgresql-8.2-postgis
Version: 1.3.1-1
Severity: important

Hi,

the uprade to postgis 1.3.1 makes the old databases unusable, because
the databases are not upgradet to the new liblwgeom.so
The /usr/share/postgresql-8.2-postgis/lwpostgis_upgrade.sql script does
not work:

psql:/usr/share/postgresql-8.2-postgis/lwpostgis_upgrade.sql:38: ERROR: could 
not access file "/usr/lib/postgresql/8.2/lib/liblwgeom.so.1.2": No such file or 
directory

ingo

-- System Information:
Debian Release: lenny/sid
  APT prefers unstable
  APT policy: (860, 'unstable'), (850, 'testing'), (800, 'stable')
Architecture: amd64 (x86_64)

Kernel: Linux 2.6.22.1 (SMP w/2 CPU cores)
Locale: LANG=C, LC_CTYPE=C (charmap=ANSI_X3.4-1968)
Shell: /bin/sh linked to /bin/dash

Versions of packages postgresql-8.2-postgis depends on:
ii  libc6                         2.6.1-2    GNU C Library: Shared libraries
ii  libgeos-c1                    2.2.3-3    Geometry engine for Geographic Inf
ii  postgis                       1.3.1-1    geographic objects support for Pos
ii  postgresql-8.2                8.2.4-3    object-relational SQL database, ve
ii  proj                          4.5.0-2    Cartographic projection filter and

postgresql-8.2-postgis recommends no packages.

-- no debconf information



--- End Message ---
--- Begin Message ---
Source: postgis
Source-Version: 1.3.3-3

We believe that the bug you reported is fixed in the latest version of
postgis, which is due to be installed in the Debian FTP archive:

libpostgis-java_1.3.3-3_all.deb
  to pool/main/p/postgis/libpostgis-java_1.3.3-3_all.deb
postgis_1.3.3-3.diff.gz
  to pool/main/p/postgis/postgis_1.3.3-3.diff.gz
postgis_1.3.3-3.dsc
  to pool/main/p/postgis/postgis_1.3.3-3.dsc
postgis_1.3.3-3_i386.deb
  to pool/main/p/postgis/postgis_1.3.3-3_i386.deb
postgresql-8.3-postgis_1.3.3-3_i386.deb
  to pool/main/p/postgis/postgresql-8.3-postgis_1.3.3-3_i386.deb



A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to [EMAIL PROTECTED],
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Francesco Paolo Lovergine <[EMAIL PROTECTED]> (supplier of updated postgis 
package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing [EMAIL PROTECTED])


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.8
Date: Mon, 09 Jun 2008 13:03:04 +0200
Source: postgis
Binary: postgresql-8.3-postgis postgis libpostgis-java
Architecture: source i386 all
Version: 1.3.3-3
Distribution: unstable
Urgency: low
Maintainer: Francesco Paolo Lovergine <[EMAIL PROTECTED]>
Changed-By: Francesco Paolo Lovergine <[EMAIL PROTECTED]>
Description: 
 libpostgis-java - geographic objects support for PostgreSQL -- JDBC support
 postgis    - geographic objects support for PostgreSQL -- common files
 postgresql-8.3-postgis - geographic objects support for PostgreSQL 8.3
Closes: 441794 441797
Changes: 
 postgis (1.3.3-3) unstable; urgency=low
 .
   * Added Vcs-* fields in debian/control.
   * Fixed download URL in debian/copyright.
   * Now it installs the shared lib in a private postgis path and makes a
     hard link in the postgres library path at configure time. That would
     allow coexistence of different flavors of the library which could be
     used by different DBs at run-time and allowing soft/hard-upgrade scripts
     working. (closes: #441794, #441797)
Checksums-Sha1: 
 dccc477e39938db7a0f861072e440ac7e93de616 1495 postgis_1.3.3-3.dsc
 d8ac42e3b5935c067e9e82b408a02fcbe5f8a5cd 9921 postgis_1.3.3-3.diff.gz
 1aac36f9567d0ff84c029656462d6eb7a449e172 442788 
postgresql-8.3-postgis_1.3.3-3_i386.deb
 c711de0ebbe6567b7473093a77b3b01fc9c5f1dc 210444 postgis_1.3.3-3_i386.deb
 83c0bf63a514580b0dd32a8d5b63f6bed90a1633 317936 libpostgis-java_1.3.3-3_all.deb
Checksums-Sha256: 
 adf0f2fa86e9877bc4559a8bec2bff74b88738001cdfae8e71fa9f162a64543a 1495 
postgis_1.3.3-3.dsc
 3ee9069b3e3e26e0173597c474afbacb996b907cc3b04c0e3797e0f49809e025 9921 
postgis_1.3.3-3.diff.gz
 d88808d695fdf211683ff9d92b5208a949d3485d1ff9dbda0377dbf4a9e0e14e 442788 
postgresql-8.3-postgis_1.3.3-3_i386.deb
 568ca5b04500c128daf14bd2b7116ed901d764cede9059c7747c503ec78c4ccf 210444 
postgis_1.3.3-3_i386.deb
 2dbab7a77d9331c23f64f79a9fb2b9d0b5a5cf7093e30bf3ea04c2feefda5681 317936 
libpostgis-java_1.3.3-3_all.deb
Files: 
 54eef8f9b2731e6357d10b4d28a05767 1495 misc optional postgis_1.3.3-3.dsc
 eecf363ddd513baa2695f6c7b2bc8b45 9921 misc optional postgis_1.3.3-3.diff.gz
 69f70e41ebfc78c1271fb06d387bf1c0 442788 misc optional 
postgresql-8.3-postgis_1.3.3-3_i386.deb
 f40af243e7f8d9420734d12f9eafc998 210444 misc optional postgis_1.3.3-3_i386.deb
 1c5842fda9ba52e5a8f7bea6febd992d 317936 science optional 
libpostgis-java_1.3.3-3_all.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.9 (GNU/Linux)

iEYEARECAAYFAkhiMlMACgkQpFNRmenyx0fGqQCfWhSlAwzomDn7GEGn1NdC7+3H
O5cAmweDdmdZQyy4hN6SSdniSBvFBsfJ
=WohA
-----END PGP SIGNATURE-----



--- End Message ---
_______________________________________________
Pkg-grass-devel mailing list
Pkg-grass-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/mailman/listinfo/pkg-grass-devel

Reply via email to