Hi Stephen,

Just a quick thing you could try: "apt-get install -f" , this should install the missing dependency and continue the postgis package installation normally. Be sure you have lenny-backports in you sources.list because the libpq5 version 8.4 is there. Note that dpkg will never download and install missing dependencies, it's not its job. It's the apt-get job. That's why you have to call apt-get to fix things and continue what dpkg started before. You can also take a look at the "gdebi" utility. It's a tool to install a .deb file and it *should* (never used it much) call apt-get itself to solve missing dependencies.

see also my comments below....

Stephen Woodbridge wrote:
Hi all,

I have just found pbuilder and I'm using it with the pkg-grass debian package definitions for geos-3.2.0 and postgis-1.5.1 building packages for lenny. This is all very cool and makes things soo much easier. I am also using some packages backports.org.

So, I have gotten things setup and have been able to build packages, but postgis and postgresql-8.3-postgis will not install giving the following error:

wood...@mappy:/u/local/src$ sudo dpkg -i postgis_1.5.1-1_amd64.deb
[sudo] password for woodbri:
(Reading database ... 75044 files and directories currently installed.)
Preparing to replace postgis 1.5.1-1 (using postgis_1.5.1-1_amd64.deb) ...
Unpacking replacement postgis ...
dpkg: dependency problems prevent configuration of postgis:
 postgis depends on libpq5 (>= 8.4~0cvs20090328); however:
  Version of libpq5 on system is 8.3.9-0lenny1.
dpkg: error processing postgis (--install):
 dependency problems - leaving unconfigured
Processing triggers for man-db ...
Errors were encountered while processing:

I have attached the postgis_1.5.1-1_amd64.build.gz from the pdebuild.

I think this might be because the control_lenny file has BOTH
   postgresql-server-dev-8.3, postgresql-server-dev-8.4
as Build-Depends for postgis.

That is ok, the package is made to build the postgis extension for both versions.

Would this not then require BOTH

libpq5 8.4~0cvs20090328 from postgresql-8.4
libpq5 8.3.9-0lenny1    from postgresql-8.3

to be part of the dependencies, probably with the later one winning or whatever?

No. libpq5 is the library that allows user programs to communicate with a postgresql server. The version of libpq5 >=8.4 is compatible to communicate with servers from PostgreSQL 8.2 or later. So it's all right that the postgis package has libpq5 >=8.4.x as dependency.

Any ideas how to fix this? Does the control file need to be split into two files one for postgresql-8.3 and one for postgresql-8.4? would the rules file need to changes also or instead of the control file?

As I said, the control and rule files are ok and build the extension for postgresql 8.3 and 8.4.

I've put a lot of time and effort into trying to resolve this, but I just don't know that much about building debian packages. Reall need to guidance and help on this one.

Best regards,

Pkg-grass-devel mailing list

Hope this help,



Alan Boudreault

Pkg-grass-devel mailing list

Reply via email to