On Tue, Jun 22, 2010 at 02:53:27PM +0800, Chun-Chung Chen wrote:
> 
> There probably should be libhdf5-*-1.6-dev packages for the people
> wanting the old API. Or, if it is really desired to have
> libhdf5-*-dev meant for 1.6, there should at least be
> libhdf5-*-1.8-dev packages that provide a way to use the 1.8 API by
> default.
> 

This approach is unviable. They would required different sonames and
libnames to allow the different libraries and API to cohexist. Something
that definitively breaks compatibility against upstream and causes
serious headaches to developers. The right apporach is adding new
functions for the new API and retaining the old API for
backcompatibility. Exactly the result of the approach adopted. 

-- 
Francesco P. Lovergine



_______________________________________________
Pkg-grass-devel mailing list
Pkg-grass-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/mailman/listinfo/pkg-grass-devel

Reply via email to