On Wed, Feb 15, 2012 at 08:17:44PM -0500, Adam C Powell IV wrote:
> Here are two other ways to solve the problem:
>       * Change the sonames of the -openmpi, -mpich[2] and -lam HDF5
>         libraries so libhdf5-7 does not conflict with libhdf5-openmpi-7
>         etc.

That's a nice (already proposed) proposal, but it diverges from upstream.
So basically doing that would imply that we have all to be committed to patch
forever (or at least until hdfgroup will change mind about that) ALL programs 
that use p-HDF5 to be compiled specifically on Debian systems.

At least currently we reversed in hdf5 a change in shlibs declaration
in order to allow mixed serial/parallel rdepends of hdf5 to be installed.
That's specifically true for instance for netcdf (which needs a rebuild now).

>       * Make a new hdf5-mpi-tools package, or a set of four (one for
>         each MPI implementation) with a meta-package depending on the
>         arch-specific MPI implementation.
That's plain a good.

> HDF5 team, what do you think?  I'd be happy to propose a patch for
> either of the above remedies.

A patch is always better. But the problem pointed above remains...

Francesco P. Lovergine

Pkg-grass-devel mailing list

Reply via email to