On Sat, Apr  7, 2012 at 03:10:19 +0200, David Kalnischkies wrote:

> Hello hdf5-maintainers!
> 
> 
> In bug #667599 we have a report from piuparts that APT is unable to
> upgrade delfin-dev from squeeze to wheezy.
> 
> The problem is that APT has to decide in this process if it wants to
> have libhdf5-1.8 (= libhdf5-openmpi-1.8.4) or libhdf5-openmpi-7
> installed and finally decides against libhdf5-openmpi-7.
> 
> Removing conflict(+provides+replaces) for libhdf5-1.8, libhdf5-1.8.4
> and libhdf5-openmpi-1.8.4 obviously prevents APT from having to
> decide between the two, so you might guess what i want to ask:
> Could you hint me at why these conflicts are in place?
> 
> A quick check regarding the filelist suggests that the "old"-style 1.8.*
> versions provided a libhdf5.so.6 library while the new one provides
> libhdf5.so.7 so I wonder if these Provides are correct at all.
> At least there seem to be no file conflicts between those packages or
> did I miss the obvious?
> 
libhdf5-openmpi-7 doesn't provide the 1.8.4 version right now, I think
that got fixed a while back (it has Provides: libhdf5-1.8, which AFAIK
is meaningless, but that shouldn't harm).  The conflicts/replaces could
most likely be removed if there's no contents overlap.

Cheers,
Julien

Attachment: signature.asc
Description: Digital signature

_______________________________________________
Pkg-grass-devel mailing list
Pkg-grass-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-grass-devel

Reply via email to