Package: libgdal-dev
Version: 1.9.0-3.1
Severity: normal

Dear Maintainer,

installing libgdal-dev on my system would remove a lot of packages:

# apt-get install libgdal-dev
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following extra packages will be installed:
  libhdf5-7 libhdf5-dev libhdf5-serial-dev
The following packages will be REMOVED:
  code-aster code-aster-dev code-aster-engine code-aster-engine-dbg 
code-aster-mpi-engine code-aster-mpi-engine-dbg
  code-aster-mpi-engine-dev code-aster-test dolfin-dev dolfin-doc gmsh 
libdeal.ii-dev libdeal.ii7.1.0 libdolfin1.0 libdolfin1.0-dbg
  libdolfin1.0-dev libfeel++-dbg libfeel++-dev libfeel++1 libhdf5-mpi-dev 
libhdf5-openmpi-7 libhdf5-openmpi-dev libmed1
  libmeep-openmpi-dev libmeep-openmpi6 libpetsc3.2 libpetsc3.2-dbg 
libpetsc3.2-dev libslepc3.2 libslepc3.2-dbg libslepc3.2-dev
  meep-openmpi petsc-dev python-dolfin salome-gui salome-gui-dev salome-kernel 
salome-kernel-dev
The following NEW packages will be installed:
  libgdal-dev libhdf5-7 libhdf5-dev libhdf5-serial-dev
0 upgraded, 4 newly installed, 38 to remove and 5 not upgraded.
Need to get 0 B/9,631 kB of archives.
After this operation, 1,561 MB disk space will be freed.
Do you want to continue [Y/n]? ^C

because libgdal-dev depends on libhdf5-serial-dev whereas other
packages depend on libhdf5-mpi-dev or libhdf5-openmpi-dev.

Would it be possible for libgdal-dev to depend on other libhdf flavors?


-- System Information:
Debian Release: wheezy/sid
  APT prefers unstable
  APT policy: (500, 'unstable'), (1, 'experimental')
Architecture: i386 (i686)

Kernel: Linux 3.2.0-3-686-pae (SMP w/1 CPU core)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash

Versions of packages libgdal-dev depends on:
ii  libc6-dev                           2.13-35
ii  libcurl4-gnutls-dev [libcurl4-dev]  7.27.0-1
ii  libdap-dev                          3.11.1-11
ii  libgdal1                            1.9.0-3.1
ii  libgeos-dev                         3.3.3-1.1
ii  libgif-dev                          4.1.6-9.1
ii  libhdf4-alt-dev                     4.2r4-13
pn  libhdf5-serial-dev                  <none>
ii  libjasper-dev                       1.900.1-13
ii  libjpeg8-dev [libjpeg-dev]          8d-1
ii  libltdl-dev [libltdl3-dev]          2.4.2-1.1
ii  libmysqlclient-dev                  5.5.25+dfsg-1
ii  libnetcdf-dev                       1:4.1.3-6+b1
ii  libpng12-dev [libpng-dev]           1.2.49-3
ii  libpq-dev                           9.2.1-1
ii  libspatialite-dev                   3.1.0~rc2-1
ii  libsqlite3-dev                      3.7.14-1
ii  libxerces-c2-dev                    2.8.0+deb1-3
ii  unixodbc-dev                        2.2.14p2-5

libgdal-dev recommends no packages.

Versions of packages libgdal-dev suggests:
ii  libgdal-doc  1.9.0-3.1

_______________________________________________
Pkg-grass-devel mailing list
Pkg-grass-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-grass-devel

Reply via email to