On Tue, Jan 29, 2013 at 10:20:20 +0100, Ana Guerrero wrote:

> Now you showed they seem to be ABI compatible, giving the possibility to 
> users 
> of installing the flavour they want would be nice to have. I checked more
> and I was thinking about to change the symbols files of libhdf5-$flavour-7 to 
> depend on  "libhdf5-7 | libhdf5-openmpi-7 | libhdf5-mpich2-7" to match 
> the shlibs file, rebuild the packages and I expect that allow again to 
> switch between implementation.
> 
Well no, I'm saying replacing serial with mpi should be fine, which is
what the current shlibs say.  I'm not at all convinced about the other
way around, though I guess if somebody wants to check that it's
possible...

> 1) Oh, the upgrade is making some packages using hdf5 impossible to install 
> together, this worked in Squeeze.Hoow is so?

Only -dev packages, AFAIK.  I still don't get how that's any different
from squeeze, where you couldn't install libhdf5-serial-dev together with
libhdf5-openmpi-1.8.4 either...

Cheers,
Julien
-- 
Julien Cristau          <julien.cris...@logilab.fr>
Logilab                 http://www.logilab.fr/
Informatique scientifique & gestion de connaissances

_______________________________________________
Pkg-grass-devel mailing list
Pkg-grass-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-grass-devel

Reply via email to