Your message dated Tue, 25 Jun 2013 18:01:25 +0000
with message-id <e1urxyt-0005ko...@franck.debian.org>
and subject line Bug#679887: fixed in gdal 1.10.0-0~exp1
has caused the Debian Bug report #679887,
regarding gdal: Port to libpoppler25 API
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact ow...@bugs.debian.org
immediately.)


-- 
679887: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=679887
Debian Bug Tracking System
Contact ow...@bugs.debian.org with problems
--- Begin Message ---
Package: gdal
Version: 1.9.0-3
Severity: normal
Tags: patch
User: ubuntu-de...@lists.ubuntu.com
Usertags: origin-ubuntu quantal ubuntu-patch

Dear Maintainer,

We are using this patch in Ubuntu to handle the changes in libpoppler's
API version 19 to version 25/26.  Please consider for Debian.

  * Track changes to libpoppler25 API.


Thanks for considering the patch.

-apw

-- System Information:
Debian Release: wheezy/sid
  APT prefers precise-updates
  APT policy: (500, 'precise-updates'), (500, 'precise-security'), (500, 
'precise-proposed'), (500, 'precise'), (100, 'precise-backports')
Architecture: amd64 (x86_64)

Kernel: Linux 3.2.0-26-generic (SMP w/2 CPU cores)
Locale: LANG=en_GB.UTF-8, LC_CTYPE=en_GB.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
diff -Nru gdal-1.9.0/debian/patches/series gdal-1.9.0/debian/patches/series
--- gdal-1.9.0/debian/patches/series	2012-06-05 13:29:19.000000000 +0100
+++ gdal-1.9.0/debian/patches/series	2012-06-13 16:49:30.000000000 +0100
@@ -9,3 +9,4 @@
 mrsid-plugin
 symver
 spatialite
+track_libpoppler25_abi_changes
diff -Nru gdal-1.9.0/debian/patches/track_libpoppler25_abi_changes gdal-1.9.0/debian/patches/track_libpoppler25_abi_changes
--- gdal-1.9.0/debian/patches/track_libpoppler25_abi_changes	1970-01-01 01:00:00.000000000 +0100
+++ gdal-1.9.0/debian/patches/track_libpoppler25_abi_changes	2012-06-13 17:15:08.000000000 +0100
@@ -0,0 +1,46 @@
+Description: Track changes to libpoppler25 API
+ Track changes to libpoppler 25 ABI.
+ .
+ startDoc now takes a PDFDoc rather than its Xref.
+ setErrorFunction -> setErrorCallback.
+Author: Andy Whitcroft <a...@ubuntu.com>
+Last-Update: 2012-06-13
+Index: gdal-1.9.0/frmts/pdf/pdfdataset.cpp
+===================================================================
+--- gdal-1.9.0.orig/frmts/pdf/pdfdataset.cpp	2012-02-20 09:48:39.000000000 +0000
++++ gdal-1.9.0/frmts/pdf/pdfdataset.cpp	2012-06-13 17:14:21.967465186 +0100
+@@ -330,7 +330,7 @@
+         SplashOutputDev *poSplashOut;
+         poSplashOut = new SplashOutputDev(splashModeRGB8, 4, gFalse, sColor);
+         PDFDoc* poDoc = poGDS->poDoc;
+-        poSplashOut->startDoc(poDoc->getXRef());
++        poSplashOut->startDoc(poDoc);
+         double dfDPI = poGDS->dfDPI;
+ 
+         /* EVIL: we modify a private member... */
+@@ -521,13 +521,14 @@
+ /************************************************************************/
+ 
+ #ifdef USE_POPPLER
+-static void PDFDatasetErrorFunction(int nPos, char *pszMsg, va_list args)
++static void PDFDatasetErrorCallback( void *data, ErrorCategory category,
++				     int nPos, char *msg )
+ {
+     CPLString osError;
+ 
+     if (nPos >= 0)
+         osError.Printf("Pos = %d, ", nPos);
+-    osError += CPLString().vPrintf(pszMsg, args);
++    osError += CPLString().Printf("%s", msg);
+ 
+     if (strcmp(osError.c_str(), "Incorrect password") == 0)
+         return;
+@@ -570,7 +571,7 @@
+     GooString* poUserPwd = NULL;
+ 
+     /* Set custom error handler for poppler errors */
+-    setErrorFunction(PDFDatasetErrorFunction);
++    setErrorCallback(PDFDatasetErrorCallback, NULL);
+ 
+     PDFDoc* poDoc = NULL;
+     ObjectAutoFree oObj;

--- End Message ---
--- Begin Message ---
Source: gdal
Source-Version: 1.10.0-0~exp1

We believe that the bug you reported is fixed in the latest version of
gdal, which is due to be installed in the Debian FTP archive.

A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 679...@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Francesco Paolo Lovergine <fran...@debian.org> (supplier of updated gdal 
package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmas...@ftp-master.debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.8
Date: Sun, 04 Apr 2013 11:39:57 +0100
Source: gdal
Binary: libgdal1h libgdal1-dev libgdal-dev libgdal-doc gdal-bin python-gdal 
python3-gdal libgdal-perl libgdal-ruby1.8 libgdal-ruby
Architecture: source i386 all
Version: 1.10.0-0~exp1
Distribution: experimental
Urgency: low
Maintainer: Debian GIS Project <pkg-grass-devel@lists.alioth.debian.org>
Changed-By: Francesco Paolo Lovergine <fran...@debian.org>
Description: 
 gdal-bin   - Geospatial Data Abstraction Library - Utility programs
 libgdal-dev - Geospatial Data Abstraction Library - Development files
 libgdal-doc - Documentation for the Geospatial Data Abstraction Library
 libgdal-perl - Perl bindings to the Geospatial Data Abstraction Library
 libgdal-ruby - Ruby bindings to the Geospatial Data Abstraction Library
 libgdal-ruby1.8 - Ruby 1.8 bindings to the Geospatial Data Abstraction Library
 libgdal1-dev - Geospatial Data Abstraction Library - Development files
 libgdal1h  - Geospatial Data Abstraction Library
 python-gdal - Python bindings to the Geospatial Data Abstraction Library
 python3-gdal - Python 3 bindings to the Geospatial Data Abstraction Library
Closes: 672738 677403 679887 684433 685695 686014
Changes: 
 gdal (1.10.0-0~exp1) experimental; urgency=low
 .
   * Moved to new LIBKML driver instead of the old KML one. It has a much
     better support for complex KML files. (closes: #685695)
   * Merged NMU 1.9.0-3.1:
     Fix "FTBFS when ruby1.9.1 installed": force building with ruby1.8:
     set variables in debian/rules and new patch force-ruby1.8 to ruby1.8.
     Thanks to C├ędric Boutillier for reviewing and testing this patch.
     (closes: #684433)
   * Added libarmadillo support.
   * Added TIFF/GEOTIFF symbols rename to definitively solve problem of
     symbol collisions for programs that both links geotiff/tiff libraries.
     This choice implies that the API does not include anymore any *tiff
     related functions: changed API declaration.
   * Policy bumped to 3.9.4. No changes required.
   * New upstream version with many fixes. All patches refreshed.
        (closes: #679887)
   * Added a Breaks: libgdal1-1.6.0. I don't know if it still makes sense,
     but for sure it does not hurt. (closes: #677403)
   * Now debian/rules should be parallel-safe for making. Thanks Gregor Hermann
     for the patch. (closes: #686014)
   * Now it depends explicitly on epsilon >= 0.9.1 by upstream.
     (closes: #672738)
Checksums-Sha1: 
 228923b4ed85452ebcf243773f4d36d1b8033657 2388 gdal_1.10.0-0~exp1.dsc
 e522b95056905e4c41047fdb42c0ca172ef3ad25 10232486 gdal_1.10.0.orig.tar.gz
 e985eecac06f7e1b5545513c81bcd329cc162bc1 1251556 
gdal_1.10.0-0~exp1.debian.tar.gz
 93e9d3599c09f6a4597f1a963e197341e24efe86 4962182 
libgdal1h_1.10.0-0~exp1_i386.deb
 5f08469adc0939a102c3cd6b03c6c116acf840d7 6493986 
libgdal-dev_1.10.0-0~exp1_i386.deb
 330d01a38ac5b05db5b59de0fcc0c8936e8818d9 364558 gdal-bin_1.10.0-0~exp1_i386.deb
 1c213cc6507d373391bb780e57ea4a9590a46f66 494946 
python-gdal_1.10.0-0~exp1_i386.deb
 fd03deb990157cc39023679f9b430c9a3dde6afd 702362 
python3-gdal_1.10.0-0~exp1_i386.deb
 afaf61c551d87d1c12f94b819b0d498470de129f 425148 
libgdal-perl_1.10.0-0~exp1_i386.deb
 2a79e3b58a49f4560f80c4be2c9e3e7dd5abaa86 279542 
libgdal-ruby1.8_1.10.0-0~exp1_i386.deb
 bb05f95791b3b50d23b52ef840ac4b31a27b15f3 121478 
libgdal-ruby_1.10.0-0~exp1_i386.deb
 200f8324fa6c7bc0ac0c3bb14bc4a5245ae77c11 121926 
libgdal1-dev_1.10.0-0~exp1_all.deb
 3edbf26b75bfcf02196c47c805c20571867387f2 2897632 
libgdal-doc_1.10.0-0~exp1_all.deb
Checksums-Sha256: 
 a09431b0f5911271d7efaa9fc3cb76afe9b44e64c7bfcafaf1985b2298b4211d 2388 
gdal_1.10.0-0~exp1.dsc
 1a9ca12bcc3a55f66bcd6654d5ff12eeddb3a26b622dd7c8872febb4f5a97487 10232486 
gdal_1.10.0.orig.tar.gz
 ad0be6893204ae9ab9e6b46d68c41283fbac2756f6aaae0a7c6bd8d17b3df029 1251556 
gdal_1.10.0-0~exp1.debian.tar.gz
 999c38a184d2e16bfd837bb251e85346d231961f009c02c5b7c8d259c4c79cdc 4962182 
libgdal1h_1.10.0-0~exp1_i386.deb
 a29863f75f2204cf693302d226bdab784d3c5db8f6b17506a32fc1abb94c3b05 6493986 
libgdal-dev_1.10.0-0~exp1_i386.deb
 5d8de6e29e4cdbe802d7b6d34b87b8579a66ac7452dba5b6f5953646bb3ff563 364558 
gdal-bin_1.10.0-0~exp1_i386.deb
 7fc8257c806cdabbaa585ed2831eeaae046e35db1162e4d00a42f3844472ce42 494946 
python-gdal_1.10.0-0~exp1_i386.deb
 0af003065feacf1f28478db00394c465832f1c993ca05ff0239c3fe84636e5cd 702362 
python3-gdal_1.10.0-0~exp1_i386.deb
 f7b65fc992b71efa046ffd2a12069c975a262cacc442457dd3cbbf62495d148c 425148 
libgdal-perl_1.10.0-0~exp1_i386.deb
 a802a64e8dd38656c993de49e71f87abde61d98afbf9512e431c497fa6a72667 279542 
libgdal-ruby1.8_1.10.0-0~exp1_i386.deb
 817d91227e3007308eb95191295882dcff5454ebd7ef348d49a54904909748fe 121478 
libgdal-ruby_1.10.0-0~exp1_i386.deb
 c38367a7895ed33f927ef9da7b46cdde3fd52672c74f604ab62200593f7de897 121926 
libgdal1-dev_1.10.0-0~exp1_all.deb
 b75b2fa4876c77e18055dcaf2a4ebfeed24e4969fb4c4c276b6b7dec935c743b 2897632 
libgdal-doc_1.10.0-0~exp1_all.deb
Files: 
 8a4499753d32e4376a275e2a91be40fe 2388 science extra gdal_1.10.0-0~exp1.dsc
 a2062d6ad09250e2ade40064bcd1a384 10232486 science extra gdal_1.10.0.orig.tar.gz
 5d329e8060198858009206326a8f5d70 1251556 science extra 
gdal_1.10.0-0~exp1.debian.tar.gz
 d24d4aed4c5ad03eaec0a671d34b5012 4962182 libs extra 
libgdal1h_1.10.0-0~exp1_i386.deb
 4440c2e94add12b0b459127ce67c92df 6493986 libdevel extra 
libgdal-dev_1.10.0-0~exp1_i386.deb
 a78b5d22570916d363c492ff7ea57cf4 364558 science extra 
gdal-bin_1.10.0-0~exp1_i386.deb
 ff2a52de4efcfc2577d6c88f58c5337f 494946 python extra 
python-gdal_1.10.0-0~exp1_i386.deb
 d9da26238a7d22c5a8ad154d41c4ac27 702362 python extra 
python3-gdal_1.10.0-0~exp1_i386.deb
 007c82ad0d0dd060ee9b872d04fe7ee4 425148 perl extra 
libgdal-perl_1.10.0-0~exp1_i386.deb
 f27895b522cabf2fadb613c61d4abc40 279542 ruby extra 
libgdal-ruby1.8_1.10.0-0~exp1_i386.deb
 43c914ae2ba0c1d9b4742ec023e6cbfe 121478 ruby extra 
libgdal-ruby_1.10.0-0~exp1_i386.deb
 5e0a3cffbb560c4b567b2fdca895c85a 121926 libdevel extra 
libgdal1-dev_1.10.0-0~exp1_all.deb
 981606a25609c2e6367923775f0b6171 2897632 doc extra 
libgdal-doc_1.10.0-0~exp1_all.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.12 (GNU/Linux)

iEYEARECAAYFAlHEZlIACgkQpFNRmenyx0fl3gCgowyU1p6ChCmASxf4XsKtmf3V
q+kAoNK2LBERTfuCdXeLrwJeaAkBe7dH
=Wh/L
-----END PGP SIGNATURE-----

--- End Message ---
_______________________________________________
Pkg-grass-devel mailing list
Pkg-grass-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-grass-devel

Reply via email to