Ok I did some further tests. I built the two reverse build dependencies of liblas-dev with my new version, checked that the resulting packages installed successfully and checked that I could successfully import the python modules.


As a result of these tests I have uploaded the NMU, final debdiff is attatched.
diff -u liblas-1.2.1/debian/control liblas-1.2.1/debian/control
--- liblas-1.2.1/debian/control
+++ liblas-1.2.1/debian/control
@@ -4,7 +4,7 @@
 Maintainer: Debian GIS Project <pkg-grass-devel@lists.alioth.debian.org>
 Uploaders: Francesco Paolo Lovergine <fran...@debian.org>
 Build-Depends: cdbs (>= 0.4.49), debhelper (>= 7), autotools-dev, 
- libgeotiff-dev, libgdal1-dev, quilt, libtiff5-dev
+ libgeotiff-dev, libgdal1-dev, quilt, libtiff5-alt-dev
 Standards-Version: 3.8.3
 Homepage: http://liblas.org/
 Vcs-Browser: http://svn.debian.org/viewsvn/pkg-grass/packages/liblas/trunk
@@ -30,7 +30,7 @@
 Package: liblas-dev
 Architecture: any
 Section: libdevel
-Depends: liblas1 (= ${binary:Version}), libtiff5-dev, libgeotiff-dev, 
libgdal1-dev, ${shlibs:Depends}, ${misc:Depends}
+Depends: liblas1 (= ${binary:Version}), libtiff5-alt-dev, libgeotiff-dev, 
libgdal1-dev, ${shlibs:Depends}, ${misc:Depends}
 Description: ASPRS LiDAR data translation library - development 
  libLAS is a C/C++ library for reading and writing ASPRS LAS versions
  1.0, 1.1 and 1.2 data. The LAS format is a sequential binary format
diff -u liblas-1.2.1/debian/rules liblas-1.2.1/debian/rules
--- liblas-1.2.1/debian/rules
+++ liblas-1.2.1/debian/rules
@@ -1,5 +1,9 @@
 #!/usr/bin/make -f
 
+export CFLAGS += $(shell pkg-config --cflags libtiff-4)
+export CXXFLAGS += $(shell pkg-config --cflags libtiff-4)
+export LDFLAGS += $(shell pkg-config --libs-only-L libtiff-4)
+
 include /usr/share/cdbs/1/rules/debhelper.mk
 include /usr/share/cdbs/1/class/autotools.mk
 include /usr/share/cdbs/1/rules/patchsys-quilt.mk
diff -u liblas-1.2.1/debian/changelog liblas-1.2.1/debian/changelog
--- liblas-1.2.1/debian/changelog
+++ liblas-1.2.1/debian/changelog
@@ -1,3 +1,13 @@
+liblas (1.2.1-5.1) unstable; urgency=medium
+
+  * Non-maintainer upload.
+  * Switch from libtiff5-dev to libtiff5-alt-dev to avoid build dependency 
+    and depdency conflicts with current geotiff. (Closes: 716872)
+  * Get information on where to find libtiff headers and libraries from
+    pkg-config so we can build successfully with libtiff5-alt-dev
+
+ -- Peter Michael Green <plugw...@debian.org>  Sat, 13 Jul 2013 18:20:50 +0000
+
 liblas (1.2.1-5) unstable; urgency=low
 
   * Now using TIFF 4.0 instead of TIFF 3.0 API. This is required to build
_______________________________________________
Pkg-grass-devel mailing list
Pkg-grass-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-grass-devel

Reply via email to