Package: libhdf5-openmpi-dev
Version: 1.8.11-5
Severity: normal

Dear Maintainer,

I installed libhdf5-openmpi-dev to build against Field3D GPU stack and wanting 
to build for parallel switched from hdf5 serial to hdf5 openmpi.

Result: 

<mpi.h> not found.

Solution:

Edit H5public.h to change the following:

#include <mpi.h>  

to

#include <openmpi/mpi.h>

Not sure if this is a proper workaround, but I can cleanly build Field3D now.


Sincerely,

Marc J. Driftmeyer



-- System Information:
Debian Release: jessie/sid
  APT prefers unstable
  APT policy: (500, 'unstable'), (1, 'experimental')
Architecture: amd64 (x86_64)

Kernel: Linux 3.11-2-amd64 (SMP w/8 CPU cores)
Locale: LANG=en_US.utf8, LC_CTYPE=en_US.utf8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash

Versions of packages libhdf5-openmpi-dev depends on:
ii  hdf5-helpers                1.8.11-5
ii  libhdf5-openmpi-7           1.8.11-5
ii  libjpeg8-dev [libjpeg-dev]  8d-2
ii  libopenmpi-dev              1.6.5-6
ii  zlib1g-dev                  1:1.2.8.dfsg-1

libhdf5-openmpi-dev recommends no packages.

Versions of packages libhdf5-openmpi-dev suggests:
pn  libhdf5-doc  <none>

-- no debconf information

-- debsums errors found:
debsums: changed file /usr/include/H5public.h (from libhdf5-openmpi-dev package)

_______________________________________________
Pkg-grass-devel mailing list
Pkg-grass-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-grass-devel

Reply via email to