Hi Ivan,

On Wed, Jan 08, 2014 at 05:26:16PM +0100, Ivan Mincik wrote:
> Hash: SHA1
> Hi Andreas, thanks for your updates. I understand every changes you have done
> except one, which is removal of Pre-Depends: dpkg (>= 1.15.6~). Lintian from
> my Ubuntu Precise is printing error now -
> data.tar.xz-member-without-dpkg-pre-depends . I will check in Lintian from
> Unstable.

I guess Ubuntu Precise is a bit aged for this.  It simply checks for the policy
version which was valid at this time.  I'd recommend to install a file



Package: lintian
Pin: release a=unstable
Pin-Priority: 605

I have no idea whether there are any side effects under Ubuntu but in Debian
this ensures you are using lintian from unstable.  For sure this requires some



deb http://http.debian.net/debian/ unstable main

or something like this and you definitely want to make sure that you
have set your preferences correctly to not mix up your Ubuntu system
with Debian unstable packages.  So take this advise with a grain of
salt!  (Should I add:  You have been warned? ;-))

The way I changed the debian/control file was to simply use

   cme fix dpkg-control

which does a pretty good job in removing unneeded stuff.  Here as
well I'm using libconfig-model from unstable via a prefereces file:



Package: libconfig-model-dpkg-perl
Pin: release a=unstable
Pin-Priority: 605

So far so simple under Debian - no idea what pitfalls might be under
Ubuntu for this approach.
> On 01/08/2014 09:16 AM, Andreas Tille wrote:
> > Moreover you are closing the ITP bug not inside the last changelog 
> > paragraph.  This is bad since it is not automatically closed when you 
> > upload (even if there are tricks to approach this I would not do this 
> > without good reasons).  Since the first paragraph is basically 
> > uninteresting from a Debian point of view I would advise to remove it and
> > use
> > 
> > * Initial release (Closes: #646131)
> > 
> > in the current entry.  I'll leave it to your decision how to handle this -
> > feel free to ask if I did not explained the issue detailed enough.
> > 
> > Finally there are some lintian issues.  You can easily fix 
> > timewarp-standards-version by setting a recent date in d/changelog.
> I have changed changelog to only one record with current timestamp.

> > lintian -i -I g-comparator_2.2.1-1_amd64.changes
> > 
> > Thanks for your work on this package
> > 
> > Andreas.
> I am trying to fix remaining Lintian errors but I am not able to push my 
> changes
> $ git push
> fatal: remote error: access denied or repository not exported:
> /git/pkg-grass/pg_comparator.git

Ahhh - strange.  What does

$ grep url .git/config

say?  It is

        url = ssh://git.debian.org/git/pkg-grass/pg_comparator.git

on my side and this should work if you can do

   ssh git.debian.org

> Any ideas ?

May be if you answer the question above ...

Kind regards



Pkg-grass-devel mailing list

Reply via email to