On 04/16/2014 10:32 PM, Matthias Klose wrote:
> sure, but I never did speak about amd64 and ppc64, and I didn't speak about
> dh_autotools but about dh_autoreconf.

Your initial bug report claims that "the config.{guess,sub} files are
out of date" - which is not the case - and that the package should
build-depend on autotools-dev, which it already does.

This tricked me into overlooking the autotools vs autoreconf difference,
sorry.

> as I did write in the bug report. The libtool.m4 is outdated. The libtool
> package in Debian has a fixed one, and you need to call dh_autoreconf to
> update it.

Understood.

Given #698765, the fact that I see AC_CANONICAL_ in configure.ac and a
difference between config.sub and config.sub.dh-orig, I think I need to
keep the calls to dh_autotools, right? Does the attached patch look okay?

Regards

Markus Wanner

diff --git a/debian/control b/debian/control
index b5e3eec..8f2274b 100644
--- a/debian/control
+++ b/debian/control
@@ -6,7 +6,7 @@ Uploaders: Stephen Frost <sfr...@debian.org>, Francesco Paolo
  Lovergine <fran...@debian.org>, Markus Wanner <mar...@bluegap.ch>,
  Bas Couwenberg <sebas...@xs4all.nl>
 Build-Depends: debhelper (>= 9), po-debconf,
- dpkg-dev (>= 1.16.1~), autotools-dev,
+ dpkg-dev (>= 1.16.1~), dh-autoreconf, autoconf2.13,
  flex, bison, rdfind, libgeos-dev (>= 3.3), libjson0-dev (>= 0.9~),
  libproj-dev (>= 4.6.0), libssl-dev, xsltproc, docbook, docbook-xsl,
  imagemagick, libcunit1-dev, dblatex, libxml2-dev (>= 2.5.0~),
diff --git a/debian/control.in b/debian/control.in
index e84e906..ae644b0 100644
--- a/debian/control.in
+++ b/debian/control.in
@@ -6,7 +6,7 @@ Uploaders: Stephen Frost <sfr...@debian.org>, Francesco Paolo
  Lovergine <fran...@debian.org>, Markus Wanner <mar...@bluegap.ch>,
  Bas Couwenberg <sebas...@xs4all.nl>
 Build-Depends: debhelper (>= 9), po-debconf,
- dpkg-dev (>= 1.16.1~), autotools-dev,
+ dpkg-dev (>= 1.16.1~), autotools-dev, dh-autoreconf, autoconf2.13,
  flex, bison, rdfind, libgeos-dev (>= 3.3), libjson0-dev (>= 0.9~),
  libproj-dev (>= 4.6.0), libssl-dev, xsltproc, docbook, docbook-xsl,
  imagemagick, libcunit1-dev, dblatex, libxml2-dev (>= 2.5.0~),
diff --git a/debian/rules b/debian/rules
index e222090..25b2119 100755
--- a/debian/rules
+++ b/debian/rules
@@ -159,6 +159,7 @@ configuration-stamp:
 	done)
 
 #	PostGIS for the most recent PostgreSQL version
+	dh_autoreconf autoreconf2.13 -- -f
 	dh_autotools-dev_updateconfig
 	./configure $(COMMON_CONFIGURE_ARGS) \
 		--datadir=\$${prefix}/share/postgresql-$(NEWEST_POSTGRES_VERSION)-postgis \
@@ -209,6 +210,7 @@ clean: debian/control
 #	Cleanup the temporary environment file.
 	rm -f postgis-check-env.tmp
 
+	dh_autoreconf_clean
 	dh_autotools-dev_restoreconfig
 	mh_clean
 	dh_clean

Attachment: signature.asc
Description: OpenPGP digital signature

_______________________________________________
Pkg-grass-devel mailing list
Pkg-grass-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-grass-devel

Reply via email to