On 10/21/2014 08:52 PM, Felix Natter wrote:
> "Sebastiaan Couwenberg" <sebas...@xs4all.nl> writes:
>> JMapViewer 1.04 contains the patch in slightly modified form, more in line
>> with the upstream coding convention.
> I would rather not like to do this, because i.e. from 1.02 to 1.03 they
> introduced incompatibilies and I had to fix freeplane, and I might
> not have enough time to fix freeplane (and josm) before the freeze :-/

That's entirely reasonable with only two weeks left until the freeze.

I mostly asked in case you missed the message by Vincent Privat in his
role as JOSM & JMapViewer upstream, who asked if it was possible to get
the new upstream version into jessie. See:


I've reviewed the changes between 1.03 and 1.04, and they are very
minimal (if you exclude whitespace changes), but two weeks may not be
enough to test the rdeps and have the updated package(s) migrate to testing.

>> Would it make sense to sponsor the new upstream version instead of the
>> patches 1.03?
> I appreciate that you reported the patch upstream so quickly, but I
> would prefer to stick with 1.03 for jessie.

Just for the record, I didn't forward the patch, Vincent Privat was
apparently following the bug report and/or mailinglist(s).

It's your call to update to 1.04 or not. I would update the packaging
and upload it to experimental at least if you have the time.

Kind Regards,


 GPG Key ID: 4096R/E88D4AF1
Fingerprint: 8182 DE41 7056 408D 6146  50D1 6750 F10A E88D 4AF1

Pkg-grass-devel mailing list

Reply via email to