Your message dated Thu, 05 Nov 2015 11:57:38 +0100
with message-id <bcf01fd5e983e4d4340819a743dcd...@xs4all.nl>
and subject line Re: Bug#804072: Cannot upload changesets
has caused the Debian Bug report #804072,
regarding Cannot upload changesets
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact ow...@bugs.debian.org
immediately.)


-- 
804072: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=804072
Debian Bug Tracking System
Contact ow...@bugs.debian.org with problems
--- Begin Message ---
Package: josm
Version: 0.0.svn8969+dfsg-2
Severity: important

The following exception is generated when I try to upload a changeset:

INFO: PUT https://api.openstreetmap.org/api/0.6/changeset/create... 
ERROR: java.lang.NoClassDefFoundError: org/apache/commons/codec/binary/Base64. 
Cause: java.lang.ClassNotFoundException: org.apache.commons.codec.binary.Base64
java.lang.NoClassDefFoundError: org/apache/commons/codec/binary/Base64
  at 
oauth.signpost.signature.OAuthMessageSigner.<init>(OAuthMessageSigner.java:37)
  at 
oauth.signpost.signature.HmacSha1MessageSigner.<init>(HmacSha1MessageSigner.java:30)
  at oauth.signpost.AbstractOAuthConsumer.<init>(AbstractOAuthConsumer.java:65)
  at 
oauth.signpost.basic.DefaultOAuthConsumer.<init>(DefaultOAuthConsumer.java:33)
  at 
org.openstreetmap.josm.data.oauth.OAuthParameters.buildConsumer(OAuthParameters.java:222)
  at 
org.openstreetmap.josm.io.OsmConnection.addOAuthAuthorizationHeader(OsmConnection.java:119)
  at org.openstreetmap.josm.io.OsmConnection.addAuth(OsmConnection.java:136)
  at org.openstreetmap.josm.io.OsmApi.sendRequest(OsmApi.java:635)
  at org.openstreetmap.josm.io.OsmApi.sendRequest(OsmApi.java:595)
  at org.openstreetmap.josm.io.OsmApi.openChangeset(OsmApi.java:425)
  at 
org.openstreetmap.josm.io.OsmServerWriter.uploadOsm(OsmServerWriter.java:205)
  at 
org.openstreetmap.josm.gui.io.UploadPrimitivesTask.realRun(UploadPrimitivesTask.java:250)
  at 
org.openstreetmap.josm.gui.PleaseWaitRunnable.doRealRun(PleaseWaitRunnable.java:93)
  at 
org.openstreetmap.josm.gui.PleaseWaitRunnable.run(PleaseWaitRunnable.java:161)
  at 
java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
  at 
java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
  at java.lang.Thread.run(Thread.java:745)
Caused by: java.lang.ClassNotFoundException: 
org.apache.commons.codec.binary.Base64
  at java.net.URLClassLoader$1.run(URLClassLoader.java:366)
  at java.net.URLClassLoader$1.run(URLClassLoader.java:355)
  at java.security.AccessController.doPrivileged(Native Method)
  at java.net.URLClassLoader.findClass(URLClassLoader.java:354)
  at java.lang.ClassLoader.loadClass(ClassLoader.java:425)
  at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:308)
  at java.lang.ClassLoader.loadClass(ClassLoader.java:358)
  ... 17 more

liboauth-signpost-java is at 1.2.1.2-1.2
libcommons-codec-java 1.10-1

-- System Information:
Debian Release: stretch/sid
  APT prefers unstable
  APT policy: (900, 'unstable'), (800, 'experimental')
Architecture: amd64 (x86_64)

Kernel: Linux 4.2.0-1-amd64 (SMP w/4 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)

Versions of packages josm depends on:
ii  default-jre [java7-runtime]      2:1.7-52.1
ii  fonts-droid                      1:4.4.4r2-7
ii  jmapviewer                       1.12+dfsg-1
ii  libcommons-compress-java         1.10-1
ii  libcommons-logging-java          1.2-1
ii  libgettext-commons-java          0.9.6-2
ii  liboauth-signpost-java           1.2.1.2-1.2
ii  libsvgsalamander-java            0~svn95-1
ii  openjdk-7-jre [java7-runtime]    7u91-2.6.2-1
ii  openstreetmap-map-icons-classic  1:0.0.svn31722-1

Versions of packages josm recommends:
pn  josm-l10n        <none>
ii  josm-plugins     0.0.svn31722+ds-1
ii  webkit-image-qt  0.0.svn25399-3

josm suggests no packages.

--- End Message ---
--- Begin Message ---
tags 804072 - unreproducible
fixed 804072 josm/0.0.svn8969+dfsg-3~exp1
thanks

On 2015-11-05 11:30, Yuri D'Elia wrote:
On 04/11/15 20:10, Sebastiaan Couwenberg wrote:
josm (0.0.svn8969+dfsg-3~exp1) was just accepted into experimental,
please test this revision if it fixes your OAuth issue after its hits
the mirrors.

It works correctly with OAuth now.

Great, thanks testing and the confirmation.

Tomorrow josm (0.0.svn8969+dfsg-2) will migrate to testing, I'll move -3 from experimental to unstable after -2 has migrated to not delay the testing migration another 5 days.

Kind Regards,

Bas

--- End Message ---
_______________________________________________
Pkg-grass-devel mailing list
Pkg-grass-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-grass-devel

Reply via email to