I don't think with can deploy two versions of a plugin in the same
package. libmodello-maven-plugin1.4-java does that [1] and it breaks
with Maven 2 (I haven't checked with Maven 3). Maven complains about the
version in the plugin descriptor not matching the version expected.

Here is the error I observed when updating maven-scm (it depends on
libmodello-maven-plugin-java and breaks if
libmodello-maven-plugin1.4-java is installed):


[INFO] Internal error in the plugin manager getting plugin
'org.codehaus.modello:modello-maven-plugin': Plugin
'org.codehaus.modello:modello-maven-plugin:1.4.x' has an invalid descriptor:
1) Plugin's descriptor contains the wrong version: 1.4.1


To work around this issue we would have to either install 2 jars in
/usr/share/maven-repo with different plugin descriptors instead of a jar
plus a symlink (this is not supported by the build helpers), or tweak
Maven to disable the version check (but is it safe?).

Emmanuel Bourg

[1]
http://packages.debian.org/sid/all/libmodello-maven-plugin1.4-java/filelist

__
This is the maintainer address of Debian's Java team
<http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-java-maintainers>. 
Please use
debian-j...@lists.debian.org for discussions and questions.

Reply via email to