On Fri, Apr 18, 2014 at 12:33 AM, Miguel Landaeta <nomad...@debian.org> wrote: > Hi Bálint, > > On Fri, Apr 18, 2014 at 12:51:38AM +0200, Bálint Réczey wrote: >> > >> > Sorry I can't be more useful for this bug at this moment. > If I uploaded groovy 2.2.1 to unstable now I would break gradle and > groovy itself by causing FTBFS on both packages. To summarize this mess: > > * gradle build-depends on itself. > * AFAICT, gradle only works with groovy 1.8.x, 6 <= x <= 9. > * groovy 1.8.6 is buildable with ant. > * groovy 2.x build-depends on gradle. > * gradle has an FTBFS already (#744337) caused by a bug introduced in groovy > 1.8.6-2. > > Evidently, groovy (and software depending on it) can't advance on this > situation. > I appreciate help and comments from the team on this issue. >
Hi Miguel, I'm looking at this too, as it stops work on building Spring using Gradle. I updated groovy to 1.8.9, and still gradle fails. So I thought about including the required dependencies to enable the groovy tests. This will prove the software performs as originally intended. So far, I've got the tests to compile but not yet run with groovy 1.8.9. I can continue with that, but I agree getting a more recent groovy would be advantageous for reasons other than gradle. Many thanks Stephen __ This is the maintainer address of Debian's Java team <http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-java-maintainers>. Please use debian-j...@lists.debian.org for discussions and questions.