FYI the packaging of the new version has started but is blocked by nasty
build issues. The work in progress is available in Git on the
maven-3.1.1 branch [1]. Any help would be welcome.

Hi, I looked into the branch for maven-3.1.1. Firstly I had to tweak some build dependencies to get started (see the attached patch for details). Once I had all the dependencies in place I ran into what I a StackOverflowError which I
assume is the issue you are refering to.

After some searching, I found a similar issue affecting Jenkins [1]. They fixed it by reverting their guice dependency to an earlier version. Note that the version where they got the error was 4.0beta5 which is also the one currently
packaged in Debian [2].

The issue was further tracked down in guice's bug tracker [3], where one of the comments mentions "You need to update to at least Sisu 0.1.0 which works with
both Guice 3 and Guice 4.0-beta5". Checking back in Debian, I see that
sisu-inject version 0.0.0.M5-1 [4] is packaged. Based on what I've read, it seems likely that upgrading sisu-inject to 0.1.0 or a later version would resolve the build problems for maven. Or in any case, allow us to proceed.

Let me know if there are any other issues where I can help. I would be happy
to get a newer version of Maven into the repository. :)

[1] https://issues.jenkins-ci.org/browse/JENKINS-26601
[2] https://tracker.debian.org/pkg/guice
[3] https://github.com/google/guice/issues/899
[4] https://tracker.debian.org/pkg/sisu-inject

--
mvh / best regards
Hans Joachim Desserud
http://desserud.org
diff --git a/debian/control b/debian/control
index e3143f7..9aebb98 100644
--- a/debian/control
+++ b/debian/control
@@ -6,10 +6,11 @@ Uploaders: Damien Raude-Morvan <draz...@debian.org>
 Build-Depends: ant, cdbs, debhelper (>= 9), default-jdk
 Build-Depends-Indep: ant-optional,
                      junit,
-                     libaether-java (>= 1:0.9.0.M2~),
                      libcommons-jxpath-java,
                      libcommons-logging-java,
                      libeasymock-java,
+                     libeclipse-aether-java,
+                     liblogback-java,
                      libmaven-ant-tasks-java (>= 2.1.3-2),
                      libmaven-clean-plugin-java (>= 2.5),
                      libmaven-compiler-plugin-java,
__
This is the maintainer address of Debian's Java team
<http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-java-maintainers>. 
Please use
debian-j...@lists.debian.org for discussions and questions.

Reply via email to