On Thu, 18 Oct 2012, tony mancill wrote:

> same location it was found in for -4.  Should there be a debian version
> under both org/jsr-305/jsr-305 and com/google/code/findbugs/jsr305 ?

Ideally, yes. I need one in com/google/code/findbugs/jsr305 at the
very least, to package minify-maven-plugin which depends on Google’s
closure-compiler, which depends on <version>debian</version> of jsr305
at least according to:
/usr/share/maven-repo/com/google/javascript/closure-compiler/debian/closure-compiler-debian.pom

Shouldn’t *every* artefact have a debian version, anyway?

Anyway, patch attached. I applied to join pkg-java on Alioth; if
that’s granted I’ll commit and team-upload it, otherwise I might
consider an NMU unless you prefer to handle this.

bye,
//mirabilos
-- 
tarent solutions GmbH
Rochusstraße 2-4, D-53123 Bonn • http://www.tarent.de/
Tel: +49 228 54881-393 • Fax: +49 228 54881-235
HRB 5168 (AG Bonn) • USt-ID (VAT): DE122264941
Geschäftsführer: Dr. Stefan Barth, Kai Ebenrett, Boris Esser, Alexander Steeg
From c1486399453d44c5f2055925377b114cd357bb10 Mon Sep 17 00:00:00 2001
From: mirabilos <t.gla...@tarent.de>
Date: Sat, 15 Oct 2016 00:18:55 +0200
Subject: [PATCH] Install a 'debian' maven version as well (Closes: #690695)

---
 debian/changelog          | 7 +++++++
 debian/maven-debian.rules | 2 ++
 debian/rules              | 9 ++++++---
 3 files changed, 15 insertions(+), 3 deletions(-)
 create mode 100644 debian/maven-debian.rules

diff --git a/debian/changelog b/debian/changelog
index 9dc35f8..3b3fa37 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+libjsr305-java (0.1~+svn49-9.1) unstable; urgency=medium
+
+  * Non-maintainer upload.
+  * Install a 'debian' maven version as well (Closes: #690695)
+
+ -- Thorsten Glaser <t...@mirbsd.de>  Sat, 15 Oct 2016 00:18:50 +0200
+
 libjsr305-java (0.1~+svn49-9) unstable; urgency=medium
 
   * Team upload.
diff --git a/debian/maven-debian.rules b/debian/maven-debian.rules
new file mode 100644
index 0000000..77cdaee
--- /dev/null
+++ b/debian/maven-debian.rules
@@ -0,0 +1,2 @@
+# Remap this version to debian in deb maven repo
+s/org.jsr-305/com.google.code.findbugs/ s/ri/jsr305/ * s/0\..*/debian/ * *
diff --git a/debian/rules b/debian/rules
index 6b4b698..351740c 100755
--- a/debian/rules
+++ b/debian/rules
@@ -23,9 +23,12 @@ get-orig-source:
 override_jh_installlibs:
 	cp ri/pom.xml debian/pom.xml
 	mh_installpom -plib$(PACKAGE)-java --no-parent --rules=debian/maven-compat.rules debian/pom.xml
-	mh_installjar -plib$(PACKAGE)-java --rules=debian/maven-compat.rules debian/pom.xml $(PACKAGE).jar 
+	mh_installjar -plib$(PACKAGE)-java --rules=debian/maven-compat.rules debian/pom.xml $(PACKAGE).jar
 	dh_link -plib$(PACKAGE)-java /usr/share/java/jsr305.jar usr/share/maven-repo/org/jsr-305/jsr305/0.1-SNAPSHOT/jsr305-0.1-SNAPSHOT.jar
+	cp ri/pom.xml debian/pom.xml
+	mh_installpom -plib$(PACKAGE)-java --no-parent --rules=debian/maven-debian.rules debian/pom.xml
+	mh_installjar -plib$(PACKAGE)-java --rules=debian/maven-debian.rules debian/pom.xml $(PACKAGE).jar
+	dh_link -plib$(PACKAGE)-java /usr/share/java/jsr305.jar usr/share/maven-repo/com/google/code/findbugs/jsr305/debian/jsr305-debian.jar
 	mh_installpoms -plib$(PACKAGE)-java
 	mh_installjar -plib$(PACKAGE)-java --usj-version=$(DEB_UPSTREAM_VERSION) \
-		-l ri/pom.xml $(PACKAGE).jar 
-
+		-l ri/pom.xml $(PACKAGE).jar
-- 
2.9.3

__
This is the maintainer address of Debian's Java team
<http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-java-maintainers>. 
Please use
debian-j...@lists.debian.org for discussions and questions.

Reply via email to