Your message dated Mon, 02 Oct 2017 15:50:26 +0000
with message-id <e1dz2zc-000cev...@fasolo.debian.org>
and subject line Bug#875322: fixed in batik 1.9-3
has caused the Debian Bug report #875322,
regarding libbatik-java: batik-1.9 causes FTBFS for freeplane due to changed 
artifacts/poms
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact ow...@bugs.debian.org
immediately.)


-- 
875322: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=875322
Debian Bug Tracking System
Contact ow...@bugs.debian.org with problems
--- Begin Message ---
Package: libbatik-java
Version: 1.9-1
Severity: important

Dear Maintainer,

freeplane depends on several batik artifacts:

   compile 'org.apache.xmlgraphics:batik-anim:1.7',
            'org.apache.xmlgraphics:batik-awt-util:1.7',
            'org.apache.xmlgraphics:batik-bridge:1.7',
            'org.apache.xmlgraphics:batik-codec:1.7',
            'org.apache.xmlgraphics:batik-css:1.7',
            'org.apache.xmlgraphics:batik-dom:1.7',
            'org.apache.xmlgraphics:batik-extension:1.7',
            'org.apache.xmlgraphics:batik-ext:1.7',
            'org.apache.xmlgraphics:batik-gui-util:1.7',
            'org.apache.xmlgraphics:batik-gvt:1.7',
            'org.apache.xmlgraphics:batik-parser:1.7',
            'org.apache.xmlgraphics:batik-script:1.7',
            'org.apache.xmlgraphics:batik-svg-dom:1.7',
            'org.apache.xmlgraphics:batik-svggen:1.7',
            'org.apache.xmlgraphics:batik-swing:1.7',
            'org.apache.xmlgraphics:batik-transcoder:1.7',
            'org.apache.xmlgraphics:batik-util:1.7',
            'org.apache.xmlgraphics:batik-xml:1.7',

This worked fine with 1.8-4, but now with 1.9-1, the compile fails due
to changed artifacts/poms:

Here is the freeplane build:

FAILURE: Build failed with an exception.

* What went wrong:
Could not resolve all dependencies for configuration 
':freeplane_plugin_svg:compileClasspath'.
> Could not resolve org.python:jython:debian.
  Required by:
      project :freeplane_plugin_svg > org.apache.xmlgraphics:batik-script:debian
   > No cached version of org.python:jython:debian available for offline mode.
   > No cached version of org.python:jython:debian available for offline mode.
> Could not resolve org.apache.xmlgraphics:batik-constants:debian.
  Required by:
      project :freeplane_plugin_svg > org.apache.xmlgraphics:batik-util:debian
   > No cached version of org.apache.xmlgraphics:batik-constants:debian 
available for offline mode.
   > No cached version of org.apache.xmlgraphics:batik-constants:debian 
available for offline mode.
> Could not resolve org.apache.xmlgraphics:batik-i18n:debian.
  Required by:
      project :freeplane_plugin_svg > org.apache.xmlgraphics:batik-util:debian
   > No cached version of org.apache.xmlgraphics:batik-i18n:debian available 
for offline mode.
   > No cached version of org.apache.xmlgraphics:batik-i18n:debian available 
for offline mode.

I don't think adding jython to (build) depends will get me far, because
batik-i18n and batik-constants are missing.

So I tried with removed batik-util and batik-script dependencies:

FAILURE: Build failed with an exception.

* What went wrong:
Could not resolve all dependencies for configuration 
':freeplane_plugin_svg:compileClasspath'.
> Could not resolve org.apache.xmlgraphics:batik-constants:debian.
  Required by:
      project :freeplane_plugin_svg > org.apache.xmlgraphics:batik-codec:debian 
> org.apache.xmlgraphics:batik-util:debian
   > No cached version of org.apache.xmlgraphics:batik-constants:debian 
available for offline mode.
   > No cached version of org.apache.xmlgraphics:batik-constants:debian 
available for offline mode.
> Could not resolve org.apache.xmlgraphics:batik-i18n:debian.
  Required by:
      project :freeplane_plugin_svg > org.apache.xmlgraphics:batik-codec:debian 
> org.apache.xmlgraphics:batik-util:debian
   > No cached version of org.apache.xmlgraphics:batik-i18n:debian available 
for offline mode.
   > No cached version of org.apache.xmlgraphics:batik-i18n:debian available 
for offline mode.
> Could not resolve org.python:jython:debian.
  Required by:
      project :freeplane_plugin_svg > org.apache.xmlgraphics:batik-swing:debian 
> org.apache.xmlgraphics:batik-script:debian
   > No cached version of org.python:jython:debian available for offline mode.
   > No cached version of org.python:jython:debian available for offline mode.

with only batik-all dependency:

:freeplane_plugin_svg:compileJava (Thread[main,5,main]) completed. Took 0.646 
secs.

FAILURE: Build failed with an exception.

* What went wrong:
Could not resolve all dependencies for configuration 
':freeplane_plugin_svg:compileClasspath'.
> Could not resolve org.apache.xmlgraphics:batik-constants:debian.
  Required by:
      project :freeplane_plugin_svg > org.apache.xmlgraphics:batik-all:debian
      project :freeplane_plugin_svg > org.apache.xmlgraphics:batik-all:debian > 
org.apache.xmlgraphics:batik-util:debian
   > No cached version of org.apache.xmlgraphics:batik-constants:debian 
available for offline mode.
   > No cached version of org.apache.xmlgraphics:batik-constants:debian 
available for offline mode.
> Could not resolve org.apache.xmlgraphics:batik-i18n:debian.
  Required by:
      project :freeplane_plugin_svg > org.apache.xmlgraphics:batik-all:debian
      project :freeplane_plugin_svg > org.apache.xmlgraphics:batik-all:debian > 
org.apache.xmlgraphics:batik-util:debian
   > No cached version of org.apache.xmlgraphics:batik-i18n:debian available 
for offline mode.
   > No cached version of org.apache.xmlgraphics:batik-i18n:debian available 
for offline mode.
> Could not resolve org.apache.xmlgraphics:batik-rasterizer-ext:debian.
  Required by:
      project :freeplane_plugin_svg > org.apache.xmlgraphics:batik-all:debian
   > No cached version of org.apache.xmlgraphics:batik-rasterizer-ext:debian 
available for offline mode.
   > No cached version of org.apache.xmlgraphics:batik-rasterizer-ext:debian 
available for offline mode.
> Could not resolve org.apache.xmlgraphics:batik-squiggle-ext:debian.
  Required by:
      project :freeplane_plugin_svg > org.apache.xmlgraphics:batik-all:debian
   > No cached version of org.apache.xmlgraphics:batik-squiggle-ext:debian 
available for offline mode.
   > No cached version of org.apache.xmlgraphics:batik-squiggle-ext:debian 
available for offline mode.
> Could not resolve org.apache.xmlgraphics:batik-svgbrowser:debian.
  Required by:
      project :freeplane_plugin_svg > org.apache.xmlgraphics:batik-all:debian
      project :freeplane_plugin_svg > org.apache.xmlgraphics:batik-all:debian > 
org.apache.xmlgraphics:batik-squiggle:debian
   > No cached version of org.apache.xmlgraphics:batik-svgbrowser:debian 
available for offline mode.
   > No cached version of org.apache.xmlgraphics:batik-svgbrowser:debian 
available for offline mode.
> Could not resolve org.apache.xmlgraphics:batik-svgrasterizer:debian.
  Required by:
      project :freeplane_plugin_svg > org.apache.xmlgraphics:batik-all:debian
      project :freeplane_plugin_svg > org.apache.xmlgraphics:batik-all:debian > 
org.apache.xmlgraphics:batik-rasterizer:debian
   > No cached version of org.apache.xmlgraphics:batik-svgrasterizer:debian 
available for offline mode.
   > No cached version of org.apache.xmlgraphics:batik-svgrasterizer:debian 
available for offline mode.
> Could not resolve org.python:jython:debian.
  Required by:
      project :freeplane_plugin_svg > org.apache.xmlgraphics:batik-all:debian > 
org.apache.xmlgraphics:batik-script:debian
   > No cached version of org.python:jython:debian available for offline mode.
   > No cached version of org.python:jython:debian available for offline mode.

I tried only batik-swing:

 problem occurred evaluating project ':freeplane_plugin_svg'.
> Could not resolve all dependencies for configuration 
> ':freeplane_plugin_svg:runtime'.
   > Could not resolve org.apache.xmlgraphics:swing:1.7.
     Required by:
         project :freeplane_plugin_svg
      > No cached version of org.apache.xmlgraphics:swing:1.7 available for 
offline mode.
      > No cached version of org.apache.xmlgraphics:swing:1.7 available for 
offline mode.

Could you please fix this?


-- System Information:
Debian Release: buster/sid
  APT prefers unstable
  APT policy: (500, 'unstable')
Architecture: amd64 (x86_64)

Kernel: Linux 4.12.0-1-amd64 (SMP w/1 CPU core)
Locale: LANG=en_US.utf8, LC_CTYPE=en_US.utf8 (charmap=UTF-8), LANGUAGE=en_US:en 
(charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)

Versions of packages libbatik-java depends on:
ii  java-wrappers                 0.1.28
ii  libbsf-java                   1:2.4.0-5
ii  libcommons-io-java            2.5-1
ii  libcommons-logging-java       1.2-1
ii  libxalan2-java                2.7.1-9
ii  libxml-commons-external-java  1.4.01-2
ii  libxmlgraphics-commons-java   2.1-2

Versions of packages libbatik-java recommends:
ii  default-jre  2:1.8-59
pn  fop          <none>
pn  rhino        <none>

libbatik-java suggests no packages.

-- no debconf information

Thanks and Best Regards,
-- 
Felix Natter
debian/rules!

--- End Message ---
--- Begin Message ---
Source: batik
Source-Version: 1.9-3

We believe that the bug you reported is fixed in the latest version of
batik, which is due to be installed in the Debian FTP archive.

A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 875...@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Emmanuel Bourg <ebo...@apache.org> (supplier of updated batik package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmas...@ftp-master.debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA512

Format: 1.8
Date: Mon, 02 Oct 2017 16:55:14 +0200
Source: batik
Binary: libbatik-java
Architecture: source
Version: 1.9-3
Distribution: unstable
Urgency: medium
Maintainer: Debian Java Maintainers 
<pkg-java-maintainers@lists.alioth.debian.org>
Changed-By: Emmanuel Bourg <ebo...@apache.org>
Description:
 libbatik-java - xml.apache.org SVG Library
Closes: 875322
Changes:
 batik (1.9-3) unstable; urgency=medium
 .
   * Team upload.
   * Made the rhino and jython dependencies optional (Closes: #875322)
   * Removed the unused dependencies on libbsf-java, libcommons-io-java
     and libcommons-logging-java
   * Build with Maven instead of Ant
   * Build with the DH sequencer instead of CDBS
   * Standards-Version updated to 4.1.1
   * Switch to debhelper level 10
Checksums-Sha1:
 69642ebc490b0de3cecd6eae91ed1ae06a9b409c 2179 batik_1.9-3.dsc
 0e41feae1ae88b8f3a2a5eb66c10348182667163 31308 batik_1.9-3.debian.tar.xz
 04e6079aa7c8938d1c87fc03a9376fd285aa7991 15496 batik_1.9-3_source.buildinfo
Checksums-Sha256:
 a76b9626128f3641edd7557fb8a2502938d112de1ceb5ef80090aadf03e68ca4 2179 
batik_1.9-3.dsc
 d5e18469b848e9f848b7f0dc10324e680c08be419e53f3d948d5b7a064328411 31308 
batik_1.9-3.debian.tar.xz
 a3c346d1198ba5ffb5a3e5d30dcdd8c7ac0fcc1387dd0c35e3ddb800055a934b 15496 
batik_1.9-3_source.buildinfo
Files:
 6a9a6ab4818dd2118f7a354529ed8504 2179 java optional batik_1.9-3.dsc
 aa245619b2e4454064868fba46da238b 31308 java optional batik_1.9-3.debian.tar.xz
 5db1b6011eb5d742a2990e8158a11572 15496 java optional 
batik_1.9-3_source.buildinfo

-----BEGIN PGP SIGNATURE-----

iQJGBAEBCgAwFiEEuM5N4hCA3PkD4WxA9RPEGeS50KwFAlnSU4ASHGVib3VyZ0Bh
cGFjaGUub3JnAAoJEPUTxBnkudCsNUwQALThqjyOt834PrL5antD7FKfmZOeTGVK
kfH38Kkm6//+9FW8VjoSptpEavCH0ivFS66DpdofITPT6jN09kP7r9ufPq4q6QVK
u/K59+ZBLPUOCNDmTBBFpbCFoPBtZyTBEO2HZ0NTqJvlStZhMoSpOWk+vOVD7Yid
Rk70BnWM+7665nrGLXA3eLwcK2+dcj/1jJFKwUX877LGJzCWBPaXXF4FNu5im+bo
qzMQopYmu0wL93fOtmHOwrXkQ5kqNZIn+UK6Hzlu5NM7fHhUjT74/EG97v98GLra
UDfglKpMyvc+LTXs92NJ3BP7p7x8pSRjU9mqUjtKN4g8oWFrpsv5gSI2PKTbcFqh
0GAmwEjAU2KwUhrSueHcWnZKa8/497988qWotR/4fOxT/ZhKhoNO3iBoLvQjhfWc
dt75Xaabgt5Wm6n3JD7Zqrt2Vw2BCpESbUiwAqnSNmJ5hdeIHb+2+oXKHVI773qB
hy/Z03bERZH6SZZ8wJX/grutEaGBUGOvwovsAFpThllL7HVm30XDQymNfaag0pRj
5Y7Y2o3G+qRoz32Y7+/iboE4GzUR6NO1ywNKDOVWS8LXfJbQHNordEytN6hzFum0
VCTxj4HC+mrmGXWM+/Um3BAKwDulIVQpX7UXG0k09wp/1y+hgU7H2h5gx+ks+xip
GXeaoTSiBS8B
=Eshm
-----END PGP SIGNATURE-----

--- End Message ---
__
This is the maintainer address of Debian's Java team
<http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-java-maintainers>. 
Please use
debian-j...@lists.debian.org for discussions and questions.

Reply via email to