Package: libjs-jquery-ui
Version: 1.8.ooops.21+dfsg-1
Severity: wishlist

It would be nice if you could also provide the various *.min.js files that
upstream does provide.

I understand that you provide jquery.ui.min.js which includes everything
but there are plenty of applications which embed a subset of the various
*.min.js files (in my case Wordpress) and it would be nice if we could
replace them with a symlink.

Ideally you would even provide pristine copy of those files so that we can
more easily identify when they are really the same files or not (this
means that you should not minify them during build unless you have changed
the original file as well). This is particularly interesting so that
people can use the "deduplicate" command of dh-linktree instead
of blindly replacing the files by symlinks.

Thank you for considering it!

-- System Information:
Debian Release: wheezy/sid
  APT prefers stable-updates
  APT policy: (500, 'stable-updates'), (500, 'proposed-updates'), (500, 
'unstable'), (500, 'testing'), (500, 'stable'), (150, 'experimental')
Architecture: i386 (x86_64)
Foreign Architectures: amd64

Kernel: Linux 3.2.0-2-amd64 (SMP w/2 CPU cores)
Locale: LANG=fr_FR.utf8, LC_CTYPE=fr_FR.utf8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages libjs-jquery-ui depends on:
ii  libjs-jquery  1.7.2+debian-1

Versions of packages libjs-jquery-ui recommends:
ii  javascript-common  8

Versions of packages libjs-jquery-ui suggests:
pn  libjs-jquery-ui-docs  <none>

-- no debconf information



_______________________________________________
Pkg-javascript-devel mailing list
Pkg-javascript-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-javascript-devel

Reply via email to