Package: node-srs
Version: 0.3.2+ds1-1
Severity: normal
Tags: patch
User: debian-...@lists.debian.org
Usertags: gdal-2.0

Dear Maintainer,

node-srs still build depends on the deprecated libgdal1-dev package.

Since gdal (1.9.0-1) libgdal-dev should be use instead.

In the upcoming gdal (2.0.0-1) the libgdal1-dev transitional package is
no longer available.

Your package will FTBFS with gdal (>= 2.0.0) when it enters the archive.

Please apply the attached patch to change the build dependency to
libgdal-dev.

Kind Regards,

Bas
>From 790c9651fea0745df3c7e3efb8003e14b0ab3b42 Mon Sep 17 00:00:00 2001
From: Bas Couwenberg <sebas...@xs4all.nl>
Date: Sun, 21 Jun 2015 15:26:16 +0200
Subject: Use libgdal-dev instead of deprecated libgdal1-dev build dependency.

---
 debian/control | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/debian/control b/debian/control
index 8c98a7d..364b3ef 100644
--- a/debian/control
+++ b/debian/control
@@ -8,7 +8,7 @@ Build-Depends:
  debhelper (>= 9~)
  , dh-buildinfo
  , node-gyp
- , libgdal1-dev (>= 1.9.0~)
+ , libgdal-dev (>= 1.9.0~)
 Standards-Version: 3.9.4
 Homepage: https://github.com/springmeyer/node-srs
 Vcs-Git: git://anoncm.debian.org/collab-maint/node-srs.git
-- 
2.1.4

_______________________________________________
Pkg-javascript-devel mailing list
Pkg-javascript-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-javascript-devel

Reply via email to