Your message dated Sun, 21 Jun 2015 19:49:02 +0000
with message-id <e1z6lek-0002uf...@franck.debian.org>
and subject line Bug#789486: fixed in node-srs 0.4.8+dfsg-1
has caused the Debian Bug report #789486,
regarding node-srs: Stop build depending on libgdal1-dev, use libgdal-dev 
instead
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact ow...@bugs.debian.org
immediately.)


-- 
789486: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=789486
Debian Bug Tracking System
Contact ow...@bugs.debian.org with problems
--- Begin Message ---
Package: node-srs
Version: 0.3.2+ds1-1
Severity: normal
Tags: patch
User: debian-...@lists.debian.org
Usertags: gdal-2.0

Dear Maintainer,

node-srs still build depends on the deprecated libgdal1-dev package.

Since gdal (1.9.0-1) libgdal-dev should be use instead.

In the upcoming gdal (2.0.0-1) the libgdal1-dev transitional package is
no longer available.

Your package will FTBFS with gdal (>= 2.0.0) when it enters the archive.

Please apply the attached patch to change the build dependency to
libgdal-dev.

Kind Regards,

Bas
>From 790c9651fea0745df3c7e3efb8003e14b0ab3b42 Mon Sep 17 00:00:00 2001
From: Bas Couwenberg <sebas...@xs4all.nl>
Date: Sun, 21 Jun 2015 15:26:16 +0200
Subject: Use libgdal-dev instead of deprecated libgdal1-dev build dependency.

---
 debian/control | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/debian/control b/debian/control
index 8c98a7d..364b3ef 100644
--- a/debian/control
+++ b/debian/control
@@ -8,7 +8,7 @@ Build-Depends:
  debhelper (>= 9~)
  , dh-buildinfo
  , node-gyp
- , libgdal1-dev (>= 1.9.0~)
+ , libgdal-dev (>= 1.9.0~)
 Standards-Version: 3.9.4
 Homepage: https://github.com/springmeyer/node-srs
 Vcs-Git: git://anoncm.debian.org/collab-maint/node-srs.git
-- 
2.1.4


--- End Message ---
--- Begin Message ---
Source: node-srs
Source-Version: 0.4.8+dfsg-1

We believe that the bug you reported is fixed in the latest version of
node-srs, which is due to be installed in the Debian FTP archive.

A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 789...@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Jérémy Lal <kapo...@melix.org> (supplier of updated node-srs package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmas...@ftp-master.debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA512

Format: 1.8
Date: Sun, 21 Jun 2015 21:36:04 +0200
Source: node-srs
Binary: node-srs
Architecture: source amd64
Version: 0.4.8+dfsg-1
Distribution: unstable
Urgency: medium
Maintainer: Debian Javascript Maintainers 
<pkg-javascript-devel@lists.alioth.debian.org>
Changed-By: Jérémy Lal <kapo...@melix.org>
Description:
 node-srs   - spatial reference library for Node.js
Closes: 789486
Changes:
 node-srs (0.4.8+dfsg-1) unstable; urgency=medium
 .
   * Imported Upstream version 0.4.8+dfsg
   * Standards-Version 3.9.6
   * Use Files-Excluded section in copyright file
   * Build-Depends gdal-dev (Closes: #789486)
   * Build-Depends node-nan
   * Update install to match upstream files layout
   * Patches:
     + remove patch that was working around non-upstream files layout
     + do not depend on node-pre-gyp for building
     + node to nodejs rename
   * Run build tests
   * Run canonical autopkgtest
   * Use gdal-config to setup symlink to srs_data instead of
     hard-coded path.
 .
   [ Mario Lang ]
   * Fix Vcs-Git URL in debian/control.
Checksums-Sha1:
 370e32df71188b09168538a8bb6716dd6026e8dc 2076 node-srs_0.4.8+dfsg-1.dsc
 b7de20e74cdeb44b52ed5c95a4431d69a55dc738 19527 node-srs_0.4.8+dfsg.orig.tar.gz
 13f933ef5356f34174a9fc16e29ec679ff9893ff 4108 
node-srs_0.4.8+dfsg-1.debian.tar.xz
 d590bd579dc61ea246f153bceeb3d1482440c680 22476 node-srs_0.4.8+dfsg-1_amd64.deb
Checksums-Sha256:
 7e42481f9a40d64fc3053c7b38351c4ffb584b190fc786dcf9c55eedfde63aa6 2076 
node-srs_0.4.8+dfsg-1.dsc
 c6fb5e1936e40436029ce0258ee6296c9ad7db6661e575b2a5a374a10b26322d 19527 
node-srs_0.4.8+dfsg.orig.tar.gz
 92acd4af7f2555090141e5cb989f1d627f56eabd6cddc5d3d64de3893d0b63df 4108 
node-srs_0.4.8+dfsg-1.debian.tar.xz
 254400a54c5c5a03a22d193d2269bb29472ed5372eb5dea5addb59e76d36b0c6 22476 
node-srs_0.4.8+dfsg-1_amd64.deb
Files:
 9d911efe1b7118aebd2ab15ec878c02e 2076 science extra node-srs_0.4.8+dfsg-1.dsc
 57ae4dceb6a27ab15d8fde941fc75a64 19527 science extra 
node-srs_0.4.8+dfsg.orig.tar.gz
 259e30ddb1300f2e6a6689d28d9b31f8 4108 science extra 
node-srs_0.4.8+dfsg-1.debian.tar.xz
 ef5d85ad37a274f2d2641be33b41e52e 22476 science extra 
node-srs_0.4.8+dfsg-1_amd64.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1

iQIcBAEBCgAGBQJVhxKtAAoJEGYRwF7dOfN0nfkP/iPan/HSII6rPmXaV4Dzxr2/
Owa632ADNEP7g2hyFStSEUrJ0TNs03sEAbbXE9VNM3Dl9qMa8aNOfDu9ONuyfb4a
tjwedMD9KxNFeOKenH8D2T391Zz2NBMo3cyE7roS9sxg5n2Yr4pS/1Xr5m3tc/P2
1F12Xfed3X6+X2ItpmDkhQIJrJtZ1UjWZg8VsNzleqXtEhfKEIVCwQJ7Z6r4X1hG
n5n6A8/kWAxnMr0jsCnYrxOT505vyVcH8DWdu5tSUdz7w2yE1zjg8bOlMIiVX88K
3SchfIio8cdoglk9kMKSjc/oA5odpc/P17T/GWiH9XWUnTUI8YWibaX6mPkq2aKI
6FbbKf9LvWUW/rHg9suLmDqXj2slsFKiMaWbm931NcVLJI9vyzM+JipQiP5YmJDE
aA8u444p3wHl+psjMhqWQaUXTNFj8cYdDnP58SgZo1+FcDCWNQNUquacA8pqPfeA
8nAEEo4ClUXQIglEGXScYK7cG3S0U+oL7Z1Te/5BiZLMHdrkzV5EDIsr2LTJ1ZFl
iOcONuqyZOMc6M0h4agSy2rFZRC0iKqdRR/nj7MGrtG5ENj+dI8Yp66AT9HPTjwF
y9HaZPtyx07Nk7ATE0KFQRN+7om1tpyGipVPnDVln1bMbnTzookGTpqSrTKKVpYr
6xyvuHDpRFEh4f1A2EYZ
=tyVQ
-----END PGP SIGNATURE-----

--- End Message ---
_______________________________________________
Pkg-javascript-devel mailing list
Pkg-javascript-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-javascript-devel

Reply via email to