Your message dated Thu, 14 Jan 2016 10:01:37 +0000
with message-id <e1ajein-0007vw...@franck.debian.org>
and subject line Bug#809845: fixed in nodejs 4.2.4~dfsg-2
has caused the Debian Bug report #809845,
regarding [PATCH] Fix autopkgtest failure due to missing gcc
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact ow...@bugs.debian.org
immediately.)


-- 
809845: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=809845
Debian Bug Tracking System
Contact ow...@bugs.debian.org with problems
--- Begin Message ---
Package: nodejs
Version: 4.2.3~dfsg-2
Tags: patch
User: ubuntu-de...@lists.ubuntu.com
Usertags: origin-ubuntu ubuntu-patch xenial

Hello,

since version 4.2.3~dfsg-2 nodejs' autopkgtests fail [1] due to

| adt-run [12:36:52]: test command1:  - - - - - - - - - - results - - - - - - - 
- - -
| command1             FAIL stderr: Can't exec "gcc": No such file or directory 
at /usr/share/perl5/Dpkg/Arch.pm line 126.
| adt-run [12:36:52]: test command1:  - - - - - - - - - - stderr - - - - - - - 
- - -
| Can't exec "gcc": No such file or directory at /usr/share/perl5/Dpkg/Arch.pm 
line 126.
| dpkg-buildflags: warning: cannot determine CC system type, falling back to 
default (native compilation)
| Can't exec "gcc": No such file or directory at /usr/share/perl5/Dpkg/Arch.pm 
line 126.

Attached trivial patch adds build-essential to the test dependencies,
which fixes the tests.

Thanks for considering,

Martin

[1] https://ci.debian.net/packages/n/nodejs/unstable/amd64/

-- 
Martin Pitt                        | http://www.piware.de
Ubuntu Developer (www.ubuntu.com)  | Debian Developer  (www.debian.org)
diff -Nru nodejs-4.2.4~dfsg/debian/changelog nodejs-4.2.4~dfsg/debian/changelog
--- nodejs-4.2.4~dfsg/debian/changelog  2015-12-24 00:59:50.000000000 +0100
+++ nodejs-4.2.4~dfsg/debian/changelog  2016-01-04 17:03:26.000000000 +0100
@@ -1,3 +1,9 @@
+nodejs (4.2.4~dfsg-1ubuntu1) xenial; urgency=medium
+
+  * debian/tests/control: Add missing build-essential test dependency.
+
+ -- Martin Pitt <martin.p...@ubuntu.com>  Mon, 04 Jan 2016 17:03:15 +0100
+
 nodejs (4.2.4~dfsg-1) unstable; urgency=medium
 
   * Imported Upstream version 4.2.4~dfsg
diff -Nru nodejs-4.2.4~dfsg/debian/tests/control 
nodejs-4.2.4~dfsg/debian/tests/control
--- nodejs-4.2.4~dfsg/debian/tests/control      2015-12-20 02:51:04.000000000 
+0100
+++ nodejs-4.2.4~dfsg/debian/tests/control      2016-01-04 17:03:12.000000000 
+0100
@@ -1,2 +1,2 @@
 Test-Command: ./debian/rules check
-Depends: @, cdbs, python, procps, curl
+Depends: @, build-essential, cdbs, python, procps, curl

--- End Message ---
--- Begin Message ---
Source: nodejs
Source-Version: 4.2.4~dfsg-2

We believe that the bug you reported is fixed in the latest version of
nodejs, which is due to be installed in the Debian FTP archive.

A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 809...@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Jérémy Lal <kapo...@melix.org> (supplier of updated nodejs package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmas...@ftp-master.debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA512

Format: 1.8
Date: Thu, 14 Jan 2016 09:39:14 +0100
Source: nodejs
Binary: nodejs-dev nodejs nodejs-dbg nodejs-legacy
Architecture: source
Version: 4.2.4~dfsg-2
Distribution: unstable
Urgency: medium
Maintainer: Debian Javascript Maintainers 
<pkg-javascript-devel@lists.alioth.debian.org>
Changed-By: Jérémy Lal <kapo...@melix.org>
Description:
 nodejs     - evented I/O for V8 javascript
 nodejs-dbg - evented I/O for V8 javascript (debug)
 nodejs-dev - evented I/O for V8 javascript (development files)
 nodejs-legacy - evented I/O for V8 javascript (legacy symlink)
Closes: 809845
Changes:
 nodejs (4.2.4~dfsg-2) unstable; urgency=medium
 .
   * tests need gcc to get DEB_HOST_ARCH,
     add build-essential as dependency. (Closes: #809845)
   * Fix install path of non-minified sh_javascript
Checksums-Sha1:
 f7a23363b8d352c9a8aa327e888646577a0179bf 2376 nodejs_4.2.4~dfsg-2.dsc
 bcece7d8e65fa1c22af2257fd73348a5942c5cf0 341716 
nodejs_4.2.4~dfsg-2.debian.tar.xz
Checksums-Sha256:
 75b59e7dc4c5aa5d3f595ff7251aad3b193101705c4552b2399431dc07bc284a 2376 
nodejs_4.2.4~dfsg-2.dsc
 8f0224b6550c349e934a4bd3535053016b7f05e44e48f57b3c591592c66220c3 341716 
nodejs_4.2.4~dfsg-2.debian.tar.xz
Files:
 396c39157cedeaab271c1aecf9ee5614 2376 web - nodejs_4.2.4~dfsg-2.dsc
 4488185dc5fc6d0c5e9422bc08678ba9 341716 web - nodejs_4.2.4~dfsg-2.debian.tar.xz

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2

iQIcBAEBCgAGBQJWl17ZAAoJEGYRwF7dOfN0CLQQALlyOFkSJX2QBthkSmwPR+MI
le618U6HlfGhq9tE/Sivax41JVHC9QpnPn+4SAdzseGxXR2aHhXeUGEn1GsKdOjn
EXm0a5qVY6ZeiAl2qkMEJgUiDumMNt3YQudf+zVFOPF8dTe1SM080ty6P6PLlVQY
0yR063I/DiFY/bkx7vM/MKg7aP6r4OgcZV+PZ97bOuQGJo2HLjDI2EOGzcI6mw9l
TKdjqmwi5hjYEzYJsOTB2ae3OOk7q5d7dIWPJBeae4Gy/HZt5ZNZEfNjrHTNyaK4
2+EUspBjRhAtp85XbHkCwI2J5JKo+8j2GUTuXogPECdSMaRHIomhi+siRED0pkfn
WToW+sBEQx3ekNY3EcAXCUuYmi1WEhUUz/7gbi2Q95vkY+yngdtOXz23JrjwAXu9
7Uxe/7lulIj/4guBe7v+pMqBltB+CLnt5hm9edhUxFH4z/iGtZ0/vc78F2i9gssL
ocmfLmxdvDyocRcbZMmi5LQn0HFdL8Frx3iQkgYfcRe7NsaJnxT8m+oqWZjNuBoR
HI0nYUBLYCkKrcq46ns5NpLuuWCJ0N5IoKlrQ/S4JnspeL1hrNehJw61tTCP+DNH
s+hMuRY0XamKaOAN5ZgQ9vNatQ4R59j0mNpGoAP2zaPRVUiAVkn+PPXtDOFR9Nf2
4SYwO4/vV/wr4sl6qJRp
=k7T+
-----END PGP SIGNATURE-----

--- End Message ---
_______________________________________________
Pkg-javascript-devel mailing list
Pkg-javascript-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-javascript-devel

Reply via email to