Package: nodejs
Version: 4.4.0~dfsg-1
Severity: grave
Tags: upstream
Justification: renders package unusable

Dear Maintainer,

   * What led up to the situation?
Need for a newer NodeJS than available in Debian-stable, in order to install a 
full Firefox-sync server.

   * What exactly did you do (or not do) that was effective (or
I first tried to apt-get source nodejs from unstable && debbuild on stable.
Then I tried to just install nodejs from unstable onto stable (changing 
As all failed, I then debootstraped Debian stretch in a chroot (systemd-nspawn).
This last test failed too so I installed the nodejs from unstable into the 

   * What was the outcome of this action?
Newer NodeJS always fail with "illegal instruction".

   * What outcome did you expect instead?
NodeJS and npm working.

-- System Information:
Debian Release: stretch/sid
  APT prefers unstable
  APT policy: (500, 'unstable')
Architecture: armel (armv5tel)

Kernel: Linux 3.16.0-4-kirkwood
Locale: LANG=C, LC_CTYPE=C (charmap=ANSI_X3.4-1968)
Shell: /bin/sh linked to /bin/dash
Init: unable to detect (that's because of systemd-nspawn; my init system is 

Versions of packages nodejs depends on:
ii  libc6        2.21-9
ii  libgcc1      1:5.3.1-11
ii  libicu55     55.1-7
ii  libssl1.0.2  1.0.2g-1
ii  libstdc++6   5.3.1-11
ii  libuv1       1.8.0-1
ii  zlib1g       1:1.2.8.dfsg-2+b1

nodejs recommends no packages.

nodejs suggests no packages.

-- no debconf information

Pkg-javascript-devel mailing list

Reply via email to