Hi there,

I'm one of the libuv maintainers.

libuv maintains strict backwards API compatibility and ABI stability, so
Node LTS will get a libuv upgrade (hopefully) soon see [0].

We follow semver, so a LTS release should be ok using the latest
vMAJOR.X, v1.x in this case.

There are a couple of annoying bugs which have delayed the backport
process, but once they are ironed out I expect  libuv 1.9.1 to land in
Node LTS.

Also note that since we follow semver, 1.8 is basically dead, not even a
security bug would make us release a 1.8.NEXT, we are in the 1.9 cycle
now, which is backwards compatible.


Cheers,

[0]: https://github.com/nodejs/node/issues/6806

-- 
Saúl Ibarra Corretgé
bettercallsaghul.com


Attachment: signature.asc
Description: OpenPGP digital signature

_______________________________________________
Pkg-javascript-devel mailing list
Pkg-javascript-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-javascript-devel

Reply via email to