On 23/12/2016 07:16, Pirate Praveen wrote:
> On ചൊവ്വ 20 ഡിസംബര്‍ 2016 03:33 വൈകു, Pirate Praveen wrote:
>> yes, in theory. In practice, babel-cli has a long chain of dependencies.
>> https://wiki.debian.org/Javascript/Nodejs/Tasks/babel-cli
> 
> babel-cli is mostly complete, but it needs lerna too
> https://wiki.debian.org/Javascript/Nodejs/Tasks/lerna

Looking at that:
- cmd-shim and read-cmd-shim you only need on windows
- inquirer I'm rushing for that too (it's required for node-yarnpkg)

So we're left with three simple packages:
- pad (*)
- progress (*)
- sync-exec (*)
two with just 1 dependency:
- command-join
- object-assign-sorted
and their dependencies which should be packaged first:
- array-from (*)
- sorted-object (*)

I am going to file the ITPs for the 5 marked with (*)

Paolo

-- 
Pkg-javascript-devel mailing list
Pkg-javascript-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-javascript-devel

Reply via email to