On 01/29/2017 02:31 PM, Jonas Smedegaard wrote: > Quoting ano...@users.sourceforge.net (2017-01-29 14:12:59) >> I've been unable to upgrade nodejs and nodejs-dev thanks to this issue: >> I need npm for some things, but also php7.0-dev (which depends on >> libssl-dev) for something else. > > Please share what it is that - transitively or not but _concurrently_ - > needs both libssl-dev.
A system with (build) dependencies for multiple packages installed. My unstable system is also affect by this issue, it has php7.0-dev installed as part of the php-geos build dependencies. Those packages need to be removed to allow the upgrade of nodejs & nodejs-dev. Because of the unholy mess that is the OpenSSL 1.1.0 transition and the complications it brings for the upcoming freeze, Julien Cristau has suggested to "go back to shipping libssl-dev as 1.0.2 for stretch, and rebuild the world" . I hope that this happens so that we get rid of issues like this one caused by libssl-dev and libssl1.0-dev conflicting.  https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=827061#1427 Kind Regards, Bas -- GPG Key ID: 4096R/6750F10AE88D4AF1 Fingerprint: 8182 DE41 7056 408D 6146 50D1 6750 F10A E88D 4AF1
Description: OpenPGP digital signature