On 03/19/2017 07:30 PM, Paul Gevers wrote:
> libwireshark-data depends on libjs-openlayers. And libjs-openlayers-doc,
> build from the same source, depends on libjs-jquery-mobile. Also horde
> depends on libjs-jquery-mobile.
> 
> [...]
> 
> However, other solutions may lay in the direction of
> removing/downgrading dependencies of libjs-openlayers on
> libjs-jquery-mobile (how much is it needed for a documentation
> package?), removing the horde dependency (apparently the Horde usage is
> broken already since 2014, see bug 749799 in CC) and similar dependency
> tree resolutions. I'll try to make time to look into this, but don't
> mind if other people beat me to it.

OpenLayers 2.x is dead upstream, they have switched to Node.js since
3.x. Packaging that turned out to be worth the effort, the dependency
chain is too large and (tiny) Node.js packages still trigger too many
discussions in Debian. The OpenLayers.js provided by libjs-openlayers
is still used by several packages, so I'd like to keep it around for a
while longer.

Based on the popcon for openlayers dropping the -doc package is not
likely to adversely affect users. If that makes life for others easier,
I'm happy to stop building that binary package.

Kind Regards,

Bas

-- 
 GPG Key ID: 4096R/6750F10AE88D4AF1
Fingerprint: 8182 DE41 7056 408D 6146  50D1 6750 F10A E88D 4AF1

Attachment: signature.asc
Description: OpenPGP digital signature

-- 
Pkg-javascript-devel mailing list
Pkg-javascript-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-javascript-devel

Reply via email to