package: node-semver
severity: grave
justification: makes it unuseable
version: 5.3.0-1
Control: block 862880 by -1

I get this error when trying to build node-at.js
(https://anonscm.debian.org/git/pkg-javascript/node-at.js.git) using
gulp 3.9.1-3

$ gulp
[10:13:56] Local gulp not found in
~/forge/debian/git/pkg-javascript/node-at.js
[10:13:56] Try running: npm install gulp
[10:13:56] Using globally installed gulp
/usr/lib/nodejs/semver/semver.js:279
    throw new TypeError('Invalid Version: ' + version);
    ^

TypeError: Invalid Version: undefined
    at new SemVer (/usr/lib/nodejs/semver/semver.js:279:11)
    at SemVer.compare (/usr/lib/nodejs/semver/semver.js:342:13)
    at compare (/usr/lib/nodejs/semver/semver.js:566:31)
    at Function.gt (/usr/lib/nodejs/semver/semver.js:595:10)
    at Liftoff.handleArguments (/usr/lib/nodejs/gulp/bin/gulp.js:99:14)
    at Liftoff.<anonymous> (/usr/lib/nodejs/liftoff/index.js:198:16)
    at module.exports (/usr/lib/nodejs/flagged-respawn/index.js:17:3)
    at Liftoff.<anonymous> (/usr/lib/nodejs/liftoff/index.js:190:9)
    at /usr/lib/nodejs/liftoff/index.js:164:9
    at /usr/lib/nodejs/v8flags/index.js:108:14

Attachment: signature.asc
Description: OpenPGP digital signature

-- 
Pkg-javascript-devel mailing list
Pkg-javascript-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-javascript-devel

Reply via email to