Your message dated Thu, 18 May 2017 07:03:57 +0000
with message-id <e1dbftz-000dmd...@fasolo.debian.org>
and subject line Bug#862888: fixed in node-gulp 3.9.1-4
has caused the Debian Bug report #862888,
regarding gulp build fail for node-at.js: TypeError: Invalid Version: undefined 
at new SemVer (/usr/lib/nodejs/semver/semver.js:279:11)
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact ow...@bugs.debian.org
immediately.)


-- 
862888: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=862888
Debian Bug Tracking System
Contact ow...@bugs.debian.org with problems
--- Begin Message ---
package: node-semver
severity: grave
justification: makes it unuseable
version: 5.3.0-1
Control: block 862880 by -1

I get this error when trying to build node-at.js
(https://anonscm.debian.org/git/pkg-javascript/node-at.js.git) using
gulp 3.9.1-3

$ gulp
[10:13:56] Local gulp not found in
~/forge/debian/git/pkg-javascript/node-at.js
[10:13:56] Try running: npm install gulp
[10:13:56] Using globally installed gulp
/usr/lib/nodejs/semver/semver.js:279
    throw new TypeError('Invalid Version: ' + version);
    ^

TypeError: Invalid Version: undefined
    at new SemVer (/usr/lib/nodejs/semver/semver.js:279:11)
    at SemVer.compare (/usr/lib/nodejs/semver/semver.js:342:13)
    at compare (/usr/lib/nodejs/semver/semver.js:566:31)
    at Function.gt (/usr/lib/nodejs/semver/semver.js:595:10)
    at Liftoff.handleArguments (/usr/lib/nodejs/gulp/bin/gulp.js:99:14)
    at Liftoff.<anonymous> (/usr/lib/nodejs/liftoff/index.js:198:16)
    at module.exports (/usr/lib/nodejs/flagged-respawn/index.js:17:3)
    at Liftoff.<anonymous> (/usr/lib/nodejs/liftoff/index.js:190:9)
    at /usr/lib/nodejs/liftoff/index.js:164:9
    at /usr/lib/nodejs/v8flags/index.js:108:14

Attachment: signature.asc
Description: OpenPGP digital signature


--- End Message ---
--- Begin Message ---
Source: node-gulp
Source-Version: 3.9.1-4

We believe that the bug you reported is fixed in the latest version of
node-gulp, which is due to be installed in the Debian FTP archive.

A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 862...@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Pirate Praveen <prav...@debian.org> (supplier of updated node-gulp package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmas...@ftp-master.debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

Format: 1.8
Date: Thu, 18 May 2017 12:09:22 +0530
Source: node-gulp
Binary: gulp
Architecture: source
Version: 3.9.1-4
Distribution: unstable
Urgency: medium
Maintainer: Debian Javascript Maintainers 
<pkg-javascript-devel@lists.alioth.debian.org>
Changed-By: Pirate Praveen <prav...@debian.org>
Description:
 gulp       - streaming build system to automate painful or time-consuming task
Closes: 862888
Changes:
 node-gulp (3.9.1-4) unstable; urgency=medium
 .
   * don't fail if local gulp is not found (Closes: #862888)
Checksums-Sha1:
 3574da6acf4848520c0418ca534bf5fdde69f925 1979 node-gulp_3.9.1-4.dsc
 307c7009374a3205a99f42600b441fe8f58a3042 3476 node-gulp_3.9.1-4.debian.tar.xz
 5ad6aee4d8d07d281cc7d8817a0b41aee7ac858d 5759 
node-gulp_3.9.1-4_source.buildinfo
Checksums-Sha256:
 f97a9f7ed563a91842ac7f418ed36acb3ef1a69f48b703ea3a6e58c142e91a6d 1979 
node-gulp_3.9.1-4.dsc
 b490736b3fa9e0a7c074821f4a21a7c795d21c00ae78d95dc7e5c458c3f90761 3476 
node-gulp_3.9.1-4.debian.tar.xz
 c326b7e0c304f38b80ad012b9923f5930c04452e1c20ec94ab13c4417bc373de 5759 
node-gulp_3.9.1-4_source.buildinfo
Files:
 e474dce2b9cc4a6fcd4c99b8e7a6c904 1979 web optional node-gulp_3.9.1-4.dsc
 91b8afb71fc3bfa46b46c1b81c03e924 3476 web optional 
node-gulp_3.9.1-4.debian.tar.xz
 403fb2feab2cffa9dbc1f964d7e70bfd 5759 web optional 
node-gulp_3.9.1-4_source.buildinfo

-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEEKnl0ri/BUtd4Z9pKzh+cZ0USwioFAlkdQrcACgkQzh+cZ0US
wipjxQ//XEduUSSdy4zD+WIEqjeqDlFO+Sk2TiYASUnDx2zXe13io49uWv7Nc/I8
CMINtzE1ZlaQ+103uTF3gA5+Yg3haXXpsGZQOIrbRIXYoRNKMLPoUZKILBf57Mbq
YSRvip1CEcZ3BTLgAwmjMezkB5KENoNevmVwnmBBCBYyzUmsI/DxxeLiH83d+9CM
4ZHltRoi7zQj2jcxAu9ijETIB4AAyvIqEhwLfAqGCKadICaWX8lP6jjgdrf3zAsd
qwZAYli+FB1XYa2IjKpUGSDV/WKtPGjStEhj6CAOPeGOmFM6YY81KFW9X29Z3XPR
oJiBzxCpqNZEXpLo9C5GAWsTTpdVp5zATvZD6Li35TjS7vjkLVj7wGYZU+bThHjI
0EPhE5b7ELE9At1BwhLdrn4ainRB0QKt2+I5616wZWFrtwaNb/RUYeoXOIb+3rQ/
IDiKZjAi4oXeBvT0T8FhXMu4iojQVvyrh96YwdjEiFd2aoXULsnAknJyJpLu3tKm
QweHtmF4aM2xw5FQdrLl+INSMa8cn2p9ITWsy7zGnVOQ0wRGlIqUISbx98083WMd
sVuT3jh66pqB4b0W6UejmeSiYoaqwvYCtqZkcinlgXW0hA3LqfILaQtnUpy74uqH
FAHwFfqlMEkJybIrjY9iL4rS+2NPyudBk2Y919wTmfig/Dw5IB0=
=utOA
-----END PGP SIGNATURE-----

--- End Message ---
-- 
Pkg-javascript-devel mailing list
Pkg-javascript-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-javascript-devel

Reply via email to