Hallo yes it's still on my todo list.

It's not in the npm registry so we can't easily (i.e. with the js_task_edit.py 
script) create a task page as for the other nodejs packages [1].

But it has quite a few  node dependencies.

As libjs-tinycon and node-jsonminify are in the archive we're left with 7 
direct dependencies:
- require-kernel, ITP #710057
- socket.io ITP [2]
- ueberdb
- express-session ITP #751885
- cheerio ITP #848315
- swagger-node-express
- measured

But then as Mike pointed out [3], there are recursive dependencies, so the 
count is higher.

For example there's 7 socket.io deps already listed as blocking bugs in the 
socket.io's ITP [2].

Then there is more which the last time I looked lacked IPTs:

Ueberdb2 deps:
node-cassandra-driver
node-rethinkdb
node-nano
node-elasticsearch

Cassandra-driver deps:
Node-long

rethinkdb deps:
bluebird

nano deps:
follow

And beware that I may have left out a few.

Finally one more difficulty is that it's hard to grasp what this stuff is all 
about.
For example from what I can tell there are several DB middlewares, so the 
question is: is this all really used ?

Anyway any help is welcome !

Paolo

[1] https://wiki.debian.org/Javascript/Nodejs/Tasks
[2] https://bugs.debian.org/707166
[3] https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=576998#138

Il 21/07/2017 09:39, Petter Reinholdtsen ha scritto:
> Hi.
> 
> Any progress on getting Etherpad into Debian?  I would love to add
> support for Etherpad to FreedomBox, but for that to happen there
> need to be maintainable packages in Debian.
> 
> Yesteday, the Software Freedom Conservancy announced that Etherpad
> join the Conservancy as a member, see
> <URL: https://sfconservancy.org/news/2017/jul/20/etherpad/ >.  Perhaps
> that might motivate more people to get Etherpad into Debian?
> 


-- 
Pkg-javascript-devel mailing list
Pkg-javascript-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-javascript-devel

Reply via email to