Hi, I have prepared the update to node-debug version 3.1.0

Note that this now depends on node-ms, whose upload was sponsored 3 weeks ago:
https://lists.alioth.debian.org/pipermail/pkg-javascript-devel/2017-November/022208.html
(but is still in the NEW queue)

It also produces a libjs-debug binary, see my message of Nov 3rd:
https://lists.alioth.debian.org/pipermail/pkg-javascript-devel/2017-November/022220.html

I could work around the problem of browserify-lite ignoring modules in 
/usr/lib/nodejs
by using the NODE_PATH environment variable as suggested in:
https://bugs.debian.org/858940
(I don't have to resolve modules recursively so that was enough)

Please someone allow me DM upload access for this package or sponsor the upload:
https://anonscm.debian.org/cgit/pkg-javascript/node-debug.git

Paolo

P.S. as a side-effect to this update, as mentioned in the ITP for node-ms:
https://bugs.debian.org/754551
all packages that import humanize from node-debug as ms must be updated to 
depend 
on node-ms instead. On closer inspection they should be only 3, so I have filed
3 bugs:
- node-connect-timeout https://bugs.debian.org/882965
- node-send https://bugs.debian.org/882963
- node-serve-favicon https://bugs.debian.org/882964

-- 
Pkg-javascript-devel mailing list
Pkg-javascript-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-javascript-devel

Reply via email to