On 2017-12-02 13:21+0100, Sébastien Villemot wrote:
> On Sat, Dec 02, 2017 at 01:08:55PM +0100, Félix Sipma wrote:
>> On 2017-11-05 21:27+0100, Jérémy Lal wrote:
>>> 2017-11-05 21:19 GMT+01:00 Félix Sipma <felix+deb...@gueux.org>:
> 
>>>> node version 8.9.0 LTS is available upstream. Could you consider packaging
>>>> it?
> 
>>> Sure, but nodejs 6.11.x first has to go in testing...
>> 
>> Is there still something preventing 6.12.x from migrating to testing?
> 
> Yes, it fails to build on mips and mipsel:
> 
> https://buildd.debian.org/status/package.php?p=nodejs

OK, thanks. More specifically, this test is failing:

not ok 1219 parallel/test-zlib
  ---
  duration_ms: 154.551
  severity: fail
  stack: |-
    buffer.js:11
        super(arg1, arg2, arg3);
        ^
    
    RangeError: Array buffer allocation failed
        at Buffer.Uint8Array (native)
        at FastBuffer (buffer.js:11:5)
        at createUnsafeBuffer (buffer.js:38:12)
        at allocate (buffer.js:181:12)
        at Function.Buffer.allocUnsafe (buffer.js:141:10)
        at Function.Buffer.concat (buffer.js:309:23)
        at 
InflateRaw.stream.Stream.stream.Stream.node.pipe.pipe.on.on.common.mustCall 
(/<<PKGBUILDDIR>>/test/parallel/test-zlib.js:153:29)
        at InflateRaw.<anonymous> (/<<PKGBUILDDIR>>/test/common/index.js:445:15)
        at emitNone (events.js:91:20)
        at InflateRaw.emit (events.js:185:7)
  ...

Could it be that the hosts ran out of RAM?

Attachment: signature.asc
Description: PGP signature

-- 
Pkg-javascript-devel mailing list
Pkg-javascript-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-javascript-devel

Reply via email to