Source: node-simple-swizzle
Version: 0.2.2-1
Severity: serious

Some recent change in unstable makes node-simple-swizzle FTBFS:

https://tests.reproducible-builds.org/debian/history/node-simple-swizzle.html
https://tests.reproducible-builds.org/debian/rb-pkg/unstable/amd64/node-simple-swizzle.html

...
   debian/rules override_dh_auto_test
make[1]: Entering directory '/build/1st/node-simple-swizzle-0.2.2'
mocha --compilers coffee:coffee-script/register -R spec
module.js:471
    throw err;
    ^

Error: Cannot find module 'is-arrayish'
    at Function.Module._resolveFilename (module.js:469:15)
    at Function.Module._load (module.js:417:25)
    at Module.require (module.js:497:17)
    at require (internal/module.js:20:19)
    at Object.<anonymous> (/build/1st/node-simple-swizzle-0.2.2/index.js:3:18)
    at Module._compile (module.js:570:32)
    at Object.Module._extensions..js (module.js:579:10)
    at Module.load (/usr/lib/coffee-script/lib/coffee-script/register.js:45:36)
    at tryModuleLoad (module.js:446:12)
    at Function.Module._load (module.js:438:3)
    at Module.require (module.js:497:17)
    at require (internal/module.js:20:19)
    at Object.<anonymous> 
(/build/1st/node-simple-swizzle-0.2.2/test/test.coffee:2:11)
    at Object.<anonymous> 
(/build/1st/node-simple-swizzle-0.2.2/test/test.coffee:1:1)
    at Module._compile (module.js:570:32)
    at Object.loadFile 
(/usr/lib/coffee-script/lib/coffee-script/register.js:16:19)
    at Module.load (/usr/lib/coffee-script/lib/coffee-script/register.js:45:36)
    at tryModuleLoad (module.js:446:12)
    at Function.Module._load (module.js:438:3)
    at Module.require (module.js:497:17)
    at require (internal/module.js:20:19)
    at /usr/lib/nodejs/mocha/lib/mocha.js:172:27
    at Array.forEach (native)
    at Mocha.loadFiles (/usr/lib/nodejs/mocha/lib/mocha.js:169:14)
    at Mocha.run (/usr/lib/nodejs/mocha/lib/mocha.js:356:31)
    at Object.<anonymous> (/usr/lib/nodejs/mocha/bin/_mocha:366:16)
    at Module._compile (module.js:570:32)
    at Object.Module._extensions..js (module.js:579:10)
    at Module.load (module.js:487:32)
    at tryModuleLoad (module.js:446:12)
    at Function.Module._load (module.js:438:3)
    at Module.runMain (module.js:604:10)
    at run (bootstrap_node.js:383:7)
    at startup (bootstrap_node.js:149:9)
    at bootstrap_node.js:496:3

debian/rules:13: recipe for target 'override_dh_auto_test' failed
make[1]: *** [override_dh_auto_test] Error 1

-- 
Pkg-javascript-devel mailing list
Pkg-javascript-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-javascript-devel

Reply via email to