On ബുധന്‍ 17 ജനുവരി 2018 07:15 വൈകു, Paolo Greppi wrote:
> But back to our issue, I follow you on 887500, but I am unsure whether 887497 
> really blocks 886404 ?
> 
> I mean, only one of the 4 Critical dependency warnings seems related to 
> /usr/lib/nodejs/base/utils.js (node-base)

Well, it is not sufficient, but necessary. So it is indeed a blocker,
but there are more blockers as you identified below :)

> The other 3 are related to:
> /usr/lib/nodejs/babel-core/lib/transformation/file/options/option-manager.js
> /usr/lib/nodejs/babel-core/lib/transformation/file/index.js
> 
> Pravi, are you sure that all the webpack "Critical dependency" warnings would 
> go away with the latest version of base ?

You are correct, I missed these warning related to babel-core.

WARNING in
/usr/lib/nodejs/babel-core/lib/transformation/file/options/option-manager.js
190:19-37 Critical dependency: the request of a dependency is an expression

WARNING in
/usr/lib/nodejs/babel-core/lib/transformation/file/options/option-manager.js
307:16-34 Critical dependency: the request of a dependency is an expression

WARNING in /usr/lib/nodejs/babel-core/lib/transformation/file/index.js
511:24-39 Critical dependency: the request of a dependency is an expression

WARNING in /usr/lib/nodejs/babel-core/lib/transformation/file/index.js
710:16-34 Critical dependency: the request of a dependency is an expression

The code below fixes babelhelpers error.

babeljs-external-helpers > dist/external-helpers.js
cat dist/external-helpers.js dist/rollup-plugin-babel.cjs.js > dist/tmp.js
mv dist/tmp.js dist/rollup-plugin-babel.cjs.js
rm dist/external-helpers.js

Attachment: signature.asc
Description: OpenPGP digital signature

-- 
Pkg-javascript-devel mailing list
Pkg-javascript-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-javascript-devel

Reply via email to